ship it shouldn't allow for multiple releases in the same config file to be started at the same time

RESOLVED FIXED

Status

P3
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2357] [shipit])

It's technically possible right now to start two releases at the same time that are using the same config file. We saw this as part of the first Thunderbird release channel release out of the esr17 repositories. It's not possible to do two releases at the same time from the same config file, so we should guard against this.

I don't think we can implement this on the web side, because we can only make guesses about config files based on branches. This probably needs to be implemented in release runner after retrieving the list of releases but before processing them.
Product: mozilla.org → Release Engineering

Updated

4 years ago
Whiteboard: [shipit] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2341] [shipit]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2341] [shipit] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2349] [shipit]

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2349] [shipit] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/2357] [shipit]
Mass component change for ship it bugs.
Component: Release Automation → Ship It
Duplicate of this bug: 1062154

Comment 3

2 years ago
Ship-it can handle multiple releases without reconfigs now! \o/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.