intermittent browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | Test timed out | Found a tab after previous test timed out

RESOLVED FIXED in Firefox 33

Status

DevTools
Inspector
RESOLVED FIXED
5 years ago
a month ago

People

(Reporter: Optimizer, Assigned: Sami Jaktholm)

Tracking

({intermittent-failure})

unspecified
Firefox 33
x86_64
Windows 7
intermittent-failure
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox31 wontfix, firefox32 wontfix, firefox33 fixed, firefox-esr24 wontfix, firefox-esr31 wontfix)

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

5 years ago
Sadly, all those green try were lying :(


14:36:26 WARNING - TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | Test timed out
14:36:29 WARNING - TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | Found a tab after previous test timed out: http://mochi.test:8888/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_search_suggestions.html
14:36:29 WARNING - TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | uncaught exception - ReferenceError: info is not defined at chrome://mochitests/content/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js:141
(Reporter)

Updated

5 years ago
Summary: TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | Test timed out | Found a tab after previous test timed out → intermittent browser/devtools/inspector/test/browser_inspector_bug_831693_searchbox_panel_navigation.js | Test timed out | Found a tab after previous test timed out
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 6

5 years ago
Created attachment 725276 [details] [diff] [review]
possible fix

Possible fix. Waiting for try results to see if I did not miss anything.

https://tbpl.mozilla.org/?tree=Try&rev=669ad5c2c402
https://tbpl.mozilla.org/?tree=Try&rev=86fd6ea6bdec
Assignee: nobody → scrapmachines
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 11

5 years ago
Comment on attachment 725276 [details] [diff] [review]
possible fix

Both trys look green to me.

I think this is ready for review.
Attachment #725276 - Flags: review?(paul)

Updated

5 years ago
Attachment #725276 - Flags: review?(paul) → review+
(Reporter)

Updated

5 years ago
Whiteboard: [land-in-fx-team]
(Reporter)

Updated

5 years ago
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Commit message fail :(

https://hg.mozilla.org/integration/fx-team/rev/f923d52bfbb1
Keywords: checkin-needed
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/f923d52bfbb1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 22
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Certainly not as frequent as it used to be, but we still are hitting it occasionally.
Status: RESOLVED → REOPENED
Flags: needinfo?(scrapmachines)
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 61

5 years ago
Certainly it has become frequent again. This seems to be a regression. Let me find out the cset that caused it.
Flags: needinfo?(scrapmachines)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 102

5 years ago
So the issue is that this._searchResults becomes intermittently null and thus line 319 od selector-search.js throws.

I will hav eot see why this._searchResults is null.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(In reply to Girish Sharma [:Optimizer] from comment #102)
> So the issue is that this._searchResults becomes intermittently null and
> thus line 319 od selector-search.js throws.
> 
> I will hav eot see why this._searchResults is null.

Thank you for looking at this btw :-)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 196

5 years ago
I have been trying for 2 days now , but unable to bring down the orange completely.

It is now failing on two cases. Both cases are linked below :

1) Fails on step 31 : https://tbpl.mozilla.org/?tree=Try&rev=70d958684114 , https://tbpl.mozilla.org/php/getParsedLog.php?id=25760753&tree=Try&full=1#error0

2) Fails due to an error response form walker actor: https://tbpl.mozilla.org/?tree=Try&rev=2090d4eec269 , https://tbpl.mozilla.org/php/getParsedLog.php?id=25762507&tree=Try&full=1#error0

Dave, help needed :)
Flags: needinfo?(dcamp)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 215

5 years ago
Do you have patches to attach that have had any positive effect?
Comment hidden (Treeherder Robot)
(Reporter)

Comment 217

5 years ago
(In reply to Dave Camp (:dcamp) from comment #215)
> Do you have patches to attach that have had any positive effect?

I have patches from both the trys that bring down the frequency a lot. But not the proper solution for 100% orange fix.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 237

5 years ago
Created attachment 782134 [details] [diff] [review]
reduces the frequency a lot but ..

I here make sure that this._searchResults is never null. But with this patch, very rarely, the this._lastQuery = .... call never returns to go inside the .then method. I wonder why.
Attachment #725276 - Attachment is obsolete: true
Attachment #782134 - Flags: feedback?(dcamp)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 260

5 years ago
Comment on attachment 782134 [details] [diff] [review]
reduces the frequency a lot but ..

Review of attachment 782134 [details] [diff] [review]:
-----------------------------------------------------------------

This patch looks good even if we need more work, do you want to land it?
Attachment #782134 - Flags: feedback?(dcamp) → feedback+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 264

5 years ago
(In reply to Dave Camp (:dcamp) from comment #260)
> Comment on attachment 782134 [details] [diff] [review]
> reduces the frequency a lot but ..
> 
> Review of attachment 782134 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This patch looks good even if we need more work, do you want to land it?

We can land it and leave this open for now.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 782134 [details] [diff] [review]
reduces the frequency a lot but ..

Review of attachment 782134 [details] [diff] [review]:
-----------------------------------------------------------------

This should take care of the formalities.
Attachment #782134 - Flags: review+
(Reporter)

Comment 282

5 years ago
landed in fx-team: https://hg.mozilla.org/integration/fx-team/rev/7647768b4706
Whiteboard: [fixed-in-fx-team][leave open]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/7647768b4706
Flags: in-testsuite+
Whiteboard: [fixed-in-fx-team][leave open] → [leave open]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/e26ddb35008b
Whiteboard: [leave open] → [test disabled][leave open]

Updated

5 years ago
Flags: needinfo?(dcamp)

Updated

4 years ago
Blocks: 992211
(Reporter)

Comment 336

4 years ago
I tried fixing this, but was unable to. Even after removing every timeout and relying solely on promises and stuff.

This test is testing only a basic functionality of the inspector popup, which in parts is also tested by other tests. (pressing up/down should populate the selected items from popup in the search box).

Thus removing myself from assignee.
Assignee: scrapmachines → nobody
(Assignee)

Comment 337

4 years ago
Created attachment 8450375 [details] [diff] [review]
fix-inspector-test-searchbox-panel-navigation.patch

Here's a patch that fixes the timeouts, cleans up and re-enables the test.

The point of the patch is that a "search-done" event is emitted from the code and the test listens to that event instead of trying to detect all six different ways for the search to complete. It would be possible to detect the search completion from the test itself but that would make the test quite complex and prone to break with future changes.

Locally I was able to run the test multiple times without problems.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=c25f20b0ae50
Attachment #8450375 - Flags: feedback?(pbrosset)
(Assignee)