Loading flash into a hidden layer.

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Alexander Shpack, Assigned: Alexander Shpack)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

17 years ago
Mozilla don't load flash movie into a hidden layer and don't hide it when layer
visibility is changed from visible to hidden. But Netscape 6.01 have a part of
this bug.

Comment 1

17 years ago
Mozilla doesn't do NS4 style layers.
Summary: Loading flash into a hidden layer. → Loading flash into a hidden layer.

Comment 2

17 years ago
NS4-style layers are not being used so they're not the issue.

I can confirm the described behavior on Win2K build 2001060703 (0.9.1).  It
looks like we are unable to change the visibility of <object>/<embed> elements
via DOM. I believe the top .swf is actually being loaded, but its visibility is
not being changed when its parent <div>'s visibility is changed, so we don't see
it.  That would make sense if the author had explicitly set the visibility of
the <object>/<embed> element (visibility of child overrides visibility of
parent) but that's not the case here.

 Maybe somewhere we are explicitly setting the visibility of plugin elements to
the visibility of their parents (on initial load), and then that's not being
updated when their parents' visibility is changed?
(Assignee)

Comment 3

17 years ago
I know, what Mozilla does not support <layer> tag :)) 

http://shadow.viva-solutions.com/bug/
Please, visit this page to view a sample (DOM only). 

Comment 4

17 years ago
Verified on
build: 2001-06-27-04-Trunk
platform: Win NT

The test case is working for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.