Mozilla hangs on startup

VERIFIED WORKSFORME

Status

SeaMonkey
General
--
critical
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Michael Raidel, Assigned: asa)

Tracking

({hang})

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)
BuildID:    2001060712

Mozilla hangs while displaying the startup screen with the following 
message: "Registering native component layout.shlb" After deleting the 
Preferences-File and trying it again it hangs while displaying "Registering 
native component MsgImap.shlb"

It is not possible to quit the program with - for example - control, command, 
escape. I always have to restart the computer..

Reproducible: Always
Steps to Reproduce:
On a Power Macintosh 6400/200, MacOS 8.6. Just double click on Mozilla and wait 
for things to happen..

Actual Results:  The mouse can be moved around but I can do nothing but restart 
the computer.

Updated

17 years ago
Keywords: hang
Reporter: Can you try it again with a fresh profile ?
(On win2k, linux : run "mozilla -profilemanager" but I know nothing about Mac )

Comment 2

17 years ago
With Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1+) Gecko/ 2001061108 on an
imac bondi blue with macos 8.6, and Mozilla starts perfectly without crashing,
is not exactly the same machine, but almost the same specs. Poster try with a
current build and a fresh profile, and post another comment if still you have
the problem.
(Reporter)

Comment 3

17 years ago
Now I tested several configurations: the same file (mozilla-mac-0.9.1-TB.sea,
build 2001060712) works fine on a G4 with System 9.1. When I copy the expanded
files from the G4 to the 6400/200, the same things happen (hangs while startup).
But when I copy the Mozilla-files from the G4 after making a "first run" on it,
they work fine on the 6400. (I deleted the Preferences file every time before I
tested a new configuration)
The startup messages of the working Mozilla are only: "Starting up" and
"component registration finished", while all the other versions show up all the
other messages, stopping with "Registering native component layout.shlb"

Comment 4

17 years ago
Not a blocker.
Severity: blocker → critical

Comment 5

17 years ago
G4 is so fast that just it don't show what is loading in the splash screen
:),lets try deleting all mozilla folders from the system and installing a fresh
build from http://ftp.mozilla.org/pub/mozilla/nightly/latest/ instead of passing
from the other machine.
(Assignee)

Comment 6

17 years ago
this works for me on a power computing 604/120 running OS 8.5

Comment 7

17 years ago
Marking it at worksforme, last tried with Mozilla/5.0 (Macintosh; U; PPC; en-US;
rv:0.9.1+) Gecko/20010615 on an imac bondi blue macos8.6, poster if the problem
persist with a fresh build feel free to reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
I just tried the same thing with the Net-Installer with the build-ID
(2001061508) and it works fine now!
verified after reporters comment
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.