Intermittent devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | In responsive mode. - Got , expected true | uncaught exception ... | Test timed out (and more)

RESOLVED FIXED in Firefox 22

Status

RESOLVED FIXED
6 years ago
3 months ago

People

(Reporter: emorley, Assigned: paul)

Tracking

({intermittent-failure})

Trunk
Firefox 22
intermittent-failure
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Created attachment 725353 [details]
Screenshot

Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-browser-chrome on 2013-03-14 15:09:33 PDT for push 3614febde426

slave: talos-r3-xp-022

https://tbpl.mozilla.org/php/getParsedLog.php?id=20660831&tree=Mozilla-Inbound

{
15:26:10     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js
15:26:11     INFO -  MOZ_EVENT_TRACE sample 1363299971015 79
15:26:11     INFO -  MOZ_EVENT_TRACE sample 1363299971140 373
15:26:11     INFO -  MOZ_EVENT_TRACE sample 1363299971171 77
15:26:11     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "data:text/html,foo" line: 0}]
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Successfully retrieved the <key> node
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Successfully retrieved keycode/key
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | In responsive mode.
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | instance of the module is attached to the tab.
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | selected item didn't change after add preset and cancel
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | number of presets didn't change after add preset and cancel
15:26:11     INFO -  MOZ_EVENT_TRACE sample 1363299971281 105
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Successfully retrieved the <key> node
15:26:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Successfully retrieved keycode/key
15:26:11  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | In responsive mode. - Got , expected true
15:26:11     INFO -  Stack trace:
15:26:11     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 486
15:26:11     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js :: restart :: line 77
15:26:11     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_executeSoon/<.run :: line 515
15:26:11     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
15:26:11  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | uncaught exception - TypeError: instance is undefined at chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js:150
15:26:11     INFO -  Stack trace:
15:26:11     INFO -      JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 1105
15:26:11     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
15:26:11     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Console message: [JavaScript Error: "TypeError: instance is undefined" {file: "chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js" line: 150}]
15:26:13     INFO -  MOZ_EVENT_TRACE sample 1363299973093 412
15:26:18     INFO -  MOZ_EVENT_TRACE sample 1363299978468 96
15:26:18     INFO -  MOZ_EVENT_TRACE sample 1363299978609 114
15:26:18     INFO -  MOZ_EVENT_TRACE sample 1363299978906 314
15:26:19     INFO -  MOZ_EVENT_TRACE sample 1363299979046 117
15:26:19     INFO -  MOZ_EVENT_TRACE sample 1363299979187 119
15:26:19     INFO -  MOZ_EVENT_TRACE sample 1363299979328 111
15:26:19     INFO -  MOZ_EVENT_TRACE sample 1363299979609 600
15:26:19     INFO -  MOZ_EVENT_TRACE sample 1363299979750 115
15:26:20     INFO -  MOZ_EVENT_TRACE sample 1363299980140 477
15:26:21     INFO -  MOZ_EVENT_TRACE sample 1363299981843 286
15:26:25     INFO -  MOZ_EVENT_TRACE sample 1363299985875 80
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986015 111
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986265 158
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986406 112
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986546 118
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986687 111
15:26:26     INFO -  MOZ_EVENT_TRACE sample 1363299986921 457
15:26:28     INFO -  MOZ_EVENT_TRACE sample 1363299988437 497
15:26:40  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Test timed out
15:26:41     INFO -  INFO TEST-END | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | finished in 30037ms
15:26:41  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/responsivedesign/test/browser_responsiveuiaddcustompreset.js | Found a tab after previous test timed out: data:text/html,foo
}
(Reporter)

Comment 1

6 years ago
Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test mochitest-browser-chrome on 2013-03-14 21:45:13 PDT for push 8f5b1f9f5804
slave: talos-mtnlion-r5-068
https://tbpl.mozilla.org/php/getParsedLog.php?id=20671829&tree=Mozilla-Inbound

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test mochitest-browser-chrome on 2013-03-15 03:45:12 PDT for push 8de291574d1a
slave: talos-mtnlion-r5-085
https://tbpl.mozilla.org/php/getParsedLog.php?id=20682701&tree=Mozilla-Inbound

Comment 2

6 years ago
Paul? Do you know how I can help?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 5

6 years ago
(In reply to hsablonniere from comment #2)
> Paul? Do you know how I can help?

I'm looking at this
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 20

6 years ago
The issue is that we use executeSoon instead of the "on" event.
(Assignee)

Comment 21

6 years ago
Created attachment 726545 [details] [diff] [review]
patch v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #726545 - Flags: review?(jwalker)
(Reporter)

Comment 22

6 years ago
Thank you for looking at this :-D
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment on attachment 726545 [details] [diff] [review]
patch v1

Review of attachment 726545 [details] [diff] [review]:
-----------------------------------------------------------------

We're still using executeSoon. Can't we ditch that now? r+ if you can explain or remove.
Attachment #726545 - Flags: review?(jwalker) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 52

6 years ago
Created attachment 728293 [details] [diff] [review]
PatchA v1.1
Attachment #726545 - Attachment is obsolete: true
Attachment #728293 - Flags: review?(jwalker)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Attachment #728293 - Flags: review?(jwalker) → review+
(Assignee)

Updated

6 years ago
Whiteboard: [land-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/integration/fx-team/rev/51dab67dc77f
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/51dab67dc77f
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 22
Comment hidden (Treeherder Robot)

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.