Editor not filtering out illegal comment syntax, causes hang

VERIFIED FIXED in mozilla1.0.1

Status

()

Core
Editor
P3
minor
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Joe Francis)

Tracking

({hang})

Trunk
mozilla1.0.1
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior] 2 days?)

(Reporter)

Description

17 years ago
Using Build ID: 2001060704

Steps to reproduce problem:
1. Start Editor
2. In HTML Source, type <pre><!----><br>Try deleting the blank line above.</pre>
(The <pre> is necessary otherwise Editor deletes the comment)
3. Switch back to normal mode.
4. (Optional) Select All and change the paragraph style to body text
5. Position the cursor on the blank line above the text.
6. Press Delete.

Expected results: Something gets deleted.

Actual results: Mozilla hangs.

Additional information: Very annoying as Composer generates this HTML.

Workaround: Delete backwards from the beginning of the line of text.

Updated

17 years ago
Severity: minor → critical
Keywords: hang

Comment 1

17 years ago
actually that is an invalid comment syntax, the proper syntax for a comment 
string is (per SGML Handbook, section 10.3):
mdo:   <!
       (comment, ( s | comment)* )?,
mdc:   -->

the ending hyphens are reserved for the close, the example you specified is 
incorrect because of the hyphen sequence used. If you separate out the comment 
as this:

<! --> it will work

however, the application should not hang, we should be either 1. removing the 
illegal comment or 2. correcting the syntax.

Changing the summary to reflect that we are not filtering illegal comment syntax
Severity: critical → minor
Keywords: hang
Priority: -- → P3
Summary: Can't delete blank line with comment (hang) → Editor not filtering out illegal comment syntax, causes hang
Whiteboard: [behavior]
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
-->jfrancis
Assignee: beppe → jfrancis
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: [behavior] → [behavior] EDITORBASE; 2 days?

Comment 3

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 4

16 years ago
removing EDITORBASE per meeting
Keywords: hang
Whiteboard: [behavior] EDITORBASE; 2 days? → [behavior] 2 days?

Comment 5

16 years ago
mdo:   <!
       (comment, ( s | comment)* )?,

True.

mdc:   -->

I don't have Goldfarb's Book right now, but i remember MDC to be > -- is COM.

Dominik
(Assignee)

Comment 6

16 years ago
fixed by earlier checkins
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

16 years ago
works ok now.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.