Closed Bug 851599 Opened 7 years ago Closed 6 years ago

The PDF reader plugin is not displaying drop shadows properly

Categories

(Firefox :: PDF Viewer, defect, P3)

19 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: support, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161)

Attachments

(2 files)

Attached image PDF_comparison.jpg
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Viewing PDFs using the FF PDF Reader Plugin.


Actual results:

A shaded box is displayed around any entities in the PDF with a drop shadow. Gradients also appear incorrectly when near a drop shadow. There is also a message warning the user that the PDF will not display properly. 


Expected results:

See examples attached below. The correct PDF appears on the left. The right image is from FF PDF Reader. Our PDF's are made using Adobe InDesign CS2 and the standard settings for outputting PDF's. The PDF's do appear correctly when using Adobe acrobat reader.
Looks similar to bug 838994.
Component: Untriaged → PDF Viewer
Whiteboard: DUPEME?
Looks like a soft mask issue, but do you have a example pdf you can link to?
Priority: -- → P4
Whiteboard: DUPEME? → [pdfjs-c-rendering][pdfjs-f-need-info]
Attached file Original PDF
The original PDF as requested.
OS: Mac OS X → All
Priority: P4 → P3
Hardware: x86 → All
Whiteboard: [pdfjs-c-rendering][pdfjs-f-need-info] → [pdfjs-c-rendering][pdfjs-d-smask]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Depends on: 965861
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.