Closed Bug 851610 Opened 9 years ago Closed 8 years ago

Make Marionette not look for fastboot for emulator tests

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(firefox22 fixed, b2g18 fixed, b2g18-v1.0.0 affected, b2g18-v1.0.1 affected)

RESOLVED FIXED
mozilla22
Tracking Status
firefox22 --- fixed
b2g18 --- fixed
b2g18-v1.0.0 --- affected
b2g18-v1.0.1 --- affected

People

(Reporter: jgriffin, Assigned: jgriffin)

Details

Attachments

(1 file)

According to ahal, when using an emulator download from releases.m.c., attempting to run unit tests on it causes this error:

Even when running these I get:
Traceback (most recent call last):
...
  File "/home/ahal/.virtualenvs/mozbase/local/lib/python2.7/site-packages/marionette_client-0.5.20-py2.7.egg/marionette/b2ginstance.py", line 49, in check_fastboot
    return cls.check_host_binary(homedir, 'fastboot')
  File "/home/ahal/.virtualenvs/mozbase/local/lib/python2.7/site-packages/marionette_client-0.5.20-py2.7.egg/marionette/b2ginstance.py", line 69, in check_host_binary
    raise Exception('%s not found!' % binary)
Exception: fastboot not found!

We shouldn't be looking for fastboot; it is never used in the emulator.
Attachment #729228 - Flags: review?(ahalberstadt)
Comment on attachment 729228 [details] [diff] [review]
Skip fastboot check for emulators

Review of attachment 729228 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #729228 - Flags: review?(ahalberstadt) → review+
https://hg.mozilla.org/mozilla-central/rev/874c83f5b5d1
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.