first tab of each window not loading on start (restart)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: landis, Unassigned)

Tracking

21 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 725588 [details]
FF-Aurora_21.0a2_Maximized_TreeStyleTabs_NotLoadingPagesOnStart_15.03.13-03.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20130315 Firefox/21.0
Build ID: 20130315042012

Steps to reproduce:

close ff (restart after update) the first page of each window (in this case 4) does not appear (load). I have recently installed, again TreeStyleTabs and Tab Scope, but have disabled Tab Scope. I can NOT remove Tab Preview or Tab Scope because Every time I touch my prefs.js file Aurora reverts to a 'default' install state. All my edits, addons are gone.


Actual results:

the first page of each window does not 'appear' or display until the window is clicked on once then it immediately appears (Much too fast to be loading from url, so it's already loaded, it just doesn't show)


Expected results:

All 'first page' or tab of each window should load upon FF start. I understand the idea or need to Not load or refresh background tabs, but the 'front page' or active tab should and always has loaded on start, restart.
(Reporter)

Comment 1

6 years ago
I should have done this, before submitting report..
I started Aurora with default (basic install) profile and opened 2 windows with tabs in each.
Restarted (Quite, Start) and the background window seemed to have loaded fine.
So, it must be an addon, most likely a tab preview addon I can't remove fully because FF reverts to basic appearance every time i touch prefs.js which is something new.

Thanks, and sorry.
Landis.
(Reporter)

Comment 2

6 years ago
Nope. New install, profile, but i copied over 'places' and with high number of tabs open background windows do Not load first page (tab) until clicked on.
(Reporter)

Comment 3

6 years ago
Created attachment 725621 [details]
new profile - large number of tabs - background windows do not load until clicked on

even with new profile, when more than 2 windows containing many tabs, on start, restart background windows do not display first or active tab content until clicked on. This is New to 21.x
Could you re-state the STR now so that we can attempt to reproduce on our end?

If I'm getting this correctly:

1. Launch Firefox
2. Install TreeStyleTabs
3. Open 4 windows with a few tabs in each.
4. Close Firefox
5. Restart Firefox.
6. Preview tabs.
...

If you state these from the beginning, the bug will be easier to follow.
Flags: needinfo?(landis)

Comment 5

6 years ago
What about hardware acceleration?
(Reporter)

Comment 6

6 years ago
this has been resolved, at least for me.. 

Thank you all.

Landis.
Flags: needinfo?(landis)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Session Restore
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.