Use cursor when loading busytimes in Store.Busytime#loadSpan

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Calendar
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: lightsofapollo, Assigned: gaye)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently we use a bounded mozGetAll search where a cursor search would be better in terms of perceived performance... With minor changes in the time controller we should show a substantial speedup to the first batch of busytimes displayed.
(Assignee)

Updated

5 years ago
Assignee: nobody → gaye
(Assignee)

Comment 1

5 years ago
Does a bug like this one deserve a performance test?
(Assignee)

Updated

5 years ago
Flags: needinfo?(jlal)
(Reporter)

Comment 2

5 years ago
I tested this while working on animations this week... it really does not work out as intended. Its still faster to use mozGetAll and then use setTimeout hacks to incrementally process the results... This is a perfect example of where having idb in a worker thread would be massively helpful... I will open up a new bug about improving the algorithm we use to load busytimes.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jlal)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.