[B2G][Contacts][Settings]: Cannot update the contact's label, the update button is grayed out.

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: sarsenyev, Assigned: crdlc)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

188 bytes, text/html
alberto.pastor
: review+
jmcf
: review+
Details
(Reporter)

Description

6 years ago
Description:
Update button is grayed out when you are trying to update the label.

Repro Steps:
1) Updated to Unagi Build ID: 20130315070220
2) Open Contacts app
3) Choose any existed contact and tap on "Edit button"( pen icon in the right corner)
4) Change the "Mobile" label to "Work" label
5) Tap "Done"

Expected:
Update button is enable and the label "Mobile" changed to the
"Work label.

Actual:
The update icon is grayed out and disable for update.

Repro frequency:
100% 

Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/78be5f74e410
Gaia: cd028015a499e4fc3a652d7aa6eb9f81a1ea8cd7

Notes:
Q Analysts Test Team Priority Rating: Pri 2

Updated

6 years ago
blocking-b2g: --- → leo?
(Assignee)

Updated

6 years ago
Assignee: nobody → crdlc
(Assignee)

Comment 1

6 years ago
Created attachment 728887 [details]
Patch v1
Attachment #728887 - Flags: review?(jmcf)
Attachment #728887 - Flags: review?(alberto.pastor)
(Assignee)

Updated

6 years ago
Status: NEW → ASSIGNED
Is this a regression?  Blocking regardless since this is pretty important functionality.
blocking-b2g: leo? → leo+
status-b2g18: --- → affected

Updated

6 years ago
Attachment #728887 - Flags: review?(jmcf) → review+
(Assignee)

Comment 3

6 years ago
It is not a regression, it has never implemented, thanks

Updated

6 years ago
Attachment #728887 - Flags: review?(alberto.pastor) → review+
(Assignee)

Comment 4

6 years ago
https://github.com/mozilla-b2g/gaia/commit/aad79d95bee682d0c5eeb53775237f3bdcc6a768
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Uplifted commit aad79d95bee682d0c5eeb53775237f3bdcc6a768 as:
v1-train: fc78e5f68e63e951e5fe12dc3ae186983bc839c3
status-b2g18: affected → fixed
Reopening as I can see this bug in v1.0.1
Status: RESOLVED → REOPENED
blocking-b2g: leo+ → tef?
status-b2g18-v1.0.1: --- → affected
Resolution: FIXED → ---
Setting qawanted to verify that v1.0.1 is affected.

Thanks.
Keywords: qawanted
(Reporter)

Comment 8

6 years ago
Environmental  Variables:
Unagi Build ID: 20130405070202
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/f35275c90b13
Gaia: 73c24b0b8fa34da37e5cbdda188595c2bd9b4c25

The bug still reproduces on "Unagi" device V1.0.1 build.
Unable to update info after changing the label
Marking as FIXED as it is already landed in master and requesting uplift via tef+
Status: REOPENED → RESOLVED
blocking-b2g: tef? → tef+
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
v1.0.1: 68f929f7a074c3bdf5b9f1065250e816ba1dfe68
status-b2g18-v1.0.1: affected → fixed

Comment 11

6 years ago
The issue is fixed on Unagi Build ID: 20130404070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/e43e65ec89d2
Gaia: daea430624ec02f8d36a12d581fc4a3278c27cb7

User is able to select Work phone number field as a valid option inside the Contact edit screen.

Verified Fixed
Status: RESOLVED → VERIFIED

Updated

6 years ago
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.