l10n build issues on central and aurora

RESOLVED FIXED

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Pike, Assigned: coop)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Being on PTO, just a quick report:

https://aus3.mozilla.org/update/3/Firefox/22.0a1/20130314030914/Darwin_x86_64-gcc3-u-i386-x86_64/de/nightly/Darwin%2011.4.2/default/default/update.xml?force=1 comes out empty, but there are mac german nightlies from the 15th.

Also, I see a host of burning depend builds on aurora, and windows nightlies seem to be busted, too. error message there is a missing l10n repo, it seems,

*** Fix above errors and then restart with               "C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py -f client.mk build"
e:\builds\moz2_slave\m-aurora-w32-l10n-ntly-0000000\build\mozilla-aurora\client.mk:321:0: command 'cd obj-firefox &&  MAKE="C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py"  e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/configure  \
  || ( echo "*** Fix above errors and then restart with\
               \"C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-aurora-w32-l10n-ntly-0000000/build/mozilla-aurora/build/pymake/pymake/../make.py -f client.mk build\"" && exit 1 )' failed, return code 1
configure: error: Invalid value --with-l10n-base, ../../l10n-central doesn't exist
I'm going to guess this is a bad mozconfig from merge day.
The comm-aurora patch in bug 851117 already has a fix for this issue for Thunderbird:

https://bugzilla.mozilla.org/attachment.cgi?id=725139
Assignee: nobody → coop
Status: NEW → ASSIGNED
Priority: -- → P2
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 784848
User impact if declined: repacks on m-a will remain broken
Testing completed (on m-c, etc.): releng rev env
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #725679 - Flags: review?(bugspam.Callek)
Attachment #725679 - Flags: approval-mozilla-aurora?
I should note that until we can do something more intelligent with paths like these in the mozconfigs, we'll need to add this to the merge day docs for relman.
Blocks: 784848
Attachment #725679 - Flags: review?(bugspam.Callek) → review+
(In reply to Axel Hecht [:Pike] from comment #5)
> Any news on the lack up updates on mac nightlies?

Axel, that might be related to bug 851539 where updates have been disabled for Nightly.
The Relman merge docs are here: https://wiki.mozilla.org/Release_Management/Merge_Documentation

Please let us know which branch merges will need to make changes to this line (ie: is beta also going to be affected?).
(In reply to Lukas Blakk [:lsblakk] from comment #7)
> The Relman merge docs are here:
> https://wiki.mozilla.org/Release_Management/Merge_Documentation
> 
> Please let us know which branch merges will need to make changes to this
> line (ie: is beta also going to be affected?).

We only use these l10n-mozconfigs for m-c and m-a right now, so the only merge affected would be m-c -> m-a. 

We would like to use mozconfigs for beta and release eventually, but I would like to eliminate the need for branch-specific l10n-base dirs before we get to that point. I'll be filing a separate bug tomorrow for that.
(In reply to Chris Cooper [:coop] from comment #8)
> We would like to use mozconfigs for beta and release eventually, but I would
> like to eliminate the need for branch-specific l10n-base dirs before we get
> to that point. I'll be filing a separate bug tomorrow for that.

i.e. There would be no extra merge activity after this change. I want to make the l10n checkout live under a standard dir across branches, say simply 'l10n.' I'm hoping to get this fixed 

Ping re: the uplift approval request. Repacks are broken on m-a instead until we get this patch. 

mozilla-central repacks are working again as of this morning.
(In reply to Chris Cooper [:coop] from comment #9)
> i.e. There would be no extra merge activity after this change. I want to
> make the l10n checkout live under a standard dir across branches, say simply
> 'l10n.' I'm hoping to get this fixed 

Filed bug 852553.
Comment on attachment 725679 [details] [diff] [review]
Fix aurora path for --with-l10n-base in mozconfigs

low risk patch that avoids broken Repacks on m-a , approving for uplift
Attachment #725679 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 725679 [details] [diff] [review]
Fix aurora path for --with-l10n-base in mozconfigs

https://hg.mozilla.org/releases/mozilla-aurora/rev/e47f2c235959
Attachment #725679 - Flags: checked-in+
We had successful repacks on aurora last night.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.