[tracker] Close threads pro-actively

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: atopal, Unassigned)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=contributors c=questions p= s=2013.backlog)

(Reporter)

Description

6 years ago
Open threads are highly ambiguous. Contributors don't know which threads are still active and what to spend their time. As a contributor I'd like to know which threads are still active by having only those open. Threads should be pro-actively closed to make identifying threads worth replying to easier. This will hopefully result in a higher rate of questions being marked as "solved".

There are various ways to achieve the above. One of them is outlined in alternative 2 on this Etherpad: https://etherpad.mozilla.org/closing-forum-threads

We should file bugs to implement that alternative.
Moving out of the sprint since it is a tracker.
Whiteboard: u=contributors c=questions p= s=2013.6 → u=contributors c=questions p= s=2013.backlog

Updated

6 years ago
Duplicate of this bug: 762001
Sorry, I am not convinced about this whole story. I don't see any data to support implementing this. Everything so far is gut feeling of what we think is happening. Can we take a step back and look at data, survey users if necessary, etc before implementing something?

I'll add my gut feeling for now too :-P. This is my opinion (which is as valid as anybody else's without any data).

1. How does closing threads quickly help the user?
I really don't see it. We are going to send them an email that they probably don't want so it's just going to be annoying. After a week, they've either solved their issue or moved on. Why would they care about it? Let's let them forget it instead of reminding them they have some issue with Firefox. If we don't have a good reason to bother the user with an email, then I think that should kill this feature right there. Mozilla responds to nobody but our users.

The etherpad says "As a user I want to know if one of the answers to a question was the solution so I don't have to try a number of non-working answers". I don't understand how closing a thread helps that at all.

2. How does closing threads quickly help contributors?
"I as a contributor want to know which threads are still worth spending time on so we can increase the number of people getting their issues resolved". Supposedly it cleans up the list of questions to work on? Which list? If I look at the default questions list you have to go back to page 39 to find a question with an answer over a week old (https://support.mozilla.org/en-US/questions?page=39). Do contributors really look all the way back there? If we don't want these questions appearing anywhere in questions lists, we can just add an extra filter and not show them by default.

3. That leaves us with us, the SUMO Team. This feature is an attempt at making our metrics look better by bothering the user with a nag email. This is the only reason I can see for this feature.


What I think we should do?
For now, don't implement anything at all in kitsune. Let's collect data and try to learn what is happening.

Let's find the users we would send the email and instead send a survey to a small sample of them. Try to find out if they are happy or not, why haven't they come back, why didn't they mark a solution, etc. (I'm not sure if we are legally allowed to do this.)

Let's sample these questions that seem "stale" and put human eyes on them. Try to infer what happened. Is there a good solution in there? Was the question really unanswerable? Did the user rage quit Firefox?

I'm sure there is a lot we can learn. Then we can try to come up with a user friendly feature to make user's happier with SUMO and Firefox.
>The etherpad says "As a user I want to know if one of the answers to a question was the >solution so I don't have to try a number of non-working answers". I don't understand how >closing a thread helps that at all.

The targeted audience for this Story isn't the original poster, it's for other users who are searching the forums and reading old forum posts. for example, Question X has been asked by user Y, and two solutions provided, but only 1 of them actually fixes the issue. User Y doesn't mark a solution. User Z searches the forum for the same issue, sees Question X, but doesn't know if the solutions there actually work, and would have to try them both to find the correct answer. This leads to extra work our users have to do, or, they may just ask another question for something that has already been answered.

>2. How does closing threads quickly help contributors?
For example, this will specifically help User Advocacy. We can search for forum threads about a specific issue right now (say, a crash) but we don't know if there is a solution/workaround unless a user comes back and says that an answer worked. This means that we have to guess or wait for a user to come back when we are trying to find a solution/workaround for a current issue.

Here's two answers/use cases.

Comment 5

6 years ago
Right, I think most of these problems can actually be solved by simply moving to a 24 hrs SLA

In the end it seems what we want to do is to convince more people to come back and mark their questions as solved. This is a valid point but again it's only gut feeling. If a reply is received very quickly in 6 or 24 hrs it is more likely for the user to come back and mark the thread as solved. If a week goes by it is unlikely he will do anything at all. We can try it and see what the impact is 

1. I as a contributor want to know which threads are still worth spending time on so we can increase the number of people getting their issues resolved."

This should be solved by just adding a filter to show the threads that haven't been replied to/solved in 24 hrs. In the end these are the threads we should make a priority to work on. The fastest the answer the more likely the user will mark stuff as solved.

2. I as a community manager want to make sure the solved KPI is clean so that the team knows how many questions we are really solving.

A way to work on this is to actually decide what "solved" really means. If we only go by the idea that only the user can decide what is solved or not we're overlooking the people who for example are just angry with the solution provided although it is the right solution. We need to set up a threshold, to what extent can the user decide and where can we step in

Just my two cents
If the problem is "users search and find the wrong stuff", then maybe the problem should be solved in search.
That isn't exactly the problem. It's if a user searches, and finds a forum thread that is their exact problem, but there are 4 answers with possible solutions, the user has to try all 4 of them in order to find an answer that helps them, rather than if a solution was marked, they could use just the solution.
(In reply to Tyler Downer [:Tyler] from comment #7)
> That isn't exactly the problem. It's if a user searches, and finds a forum
> thread that is their exact problem, but there are 4 answers with possible
> solutions, the user has to try all 4 of them in order to find an answer that
> helps them, rather than if a solution was marked, they could use just the
> solution.

That's pretty specific scenario. Also, from comment #4 and comment #7, I think you're talking about something completely different than this bug. This bug is about contributors--not users. I think you should write up a new bug for the problem you're talking about and trying to solve.
Well it's about both contributors and users, I'm failing to see a disconnect between the two.
No, it's not. It's entirely about solving problems that contributors have. Please re-read the description.
Yes, however, the etherpad (https://etherpad.mozilla.org/closing-forum-threads) linked to from the first comment has this:

>*I as a contributor want to know which threads are still worth spending time on so we can >increase the number of people getting their issues resolved
>*I as a community manager want to make sure the solved KPI is clean so that the team knows >how many questions we are really solving
>*As a user I want to know if one of the answers to a question was the solution so I don't >have to try a number of non-working answers

Basically I can see this helping in a few different ways (with users finding solutions to their problems, helping us track solved KPI more effectively, etc) and I think that the potential negative impact is being over estimated. If a user comes to the forums, and never comes back it means one of 2 things:
1. They forgot about the question (if it wasn't a big issue in Firefox, or they resolved it on their own). This reminder will then prompt them to either come back and say "Yes it's still happening" or "No, I resolved it by doing X". This is a Win-Win
2. They left Firefox. In which case, they are already gone, so we aren't losing here. This is a loss, but not sending a reminder isn't going to change this, if anything it might convince them to give Firefox one last shot.

Comment 12

6 years ago
This bugs seems to address the 3 users stories that Tyler is pointing out. That say, we jump straight away into a solution that seems not to convince everybody. From what I read, Will, Ricky and Madalina. You can add me to that group.

I think that this bug may work really well for the third user story and the first two only benefit marginally. 

Tyler's reasoning is good, but Ricky's are as valid and I will not risk annoying users more than they already are.

As Madalina points out, there are several projects addressing these 3 user stories including bigger motivation to answer questions quickly and HTML emails to mention a couple.

I would like to spend some additional time to think about a better solution to:
- Reduce the amount of Contributors work.
- Increase the resolution of threads (i.e. closing them as solved, duplicated, etc)

Some ideas:
- Auto suggest duplicated threads
- Allow users with a duplicate thread to mark an answer as a solution in a different thread.
- Allow registered users who vote to say they have the same issue to mark an answer as a solution.
- Allow users to vote an answer as a solution and graduate it to a solution after a certain threshold (with 10 solution votes, the answer becomes a solution unless the OP comes and says the opposite).
Q1 is in the past. Moving to the future.
Target Milestone: 2013Q1 → Future
(Reporter)

Comment 14

5 years ago
Uh, there is new information in here.

In a meeting following the bug discussion we decided to wait and see if HTML emails and the styling options we have with them would solve the issue of people not clicking on the "This solved my problem" button. We have HTML emails now and a proposed redesign for HTML emails for questions. That one is tracked in bug 876477.

We'll need to come back to this bug once we have results after implementing the style changes.
Blocks: 876477
(Reporter)

Comment 15

5 years ago
HTML-Emails didn't actually help, but we've decided to use a different strategy that is outlined in bug 936718. So. I'm closing this one.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.