If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MailChimp email links open as empty tabs in Firefox 19.0.2

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Lisa, Unassigned)

Tracking

19 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.17 (KHTML, like Gecko) Version/6.0.2 Safari/536.26.17

Steps to reproduce:

Followed link from MailChimp generated email newsletter. Here is an example link that loaded in the URL field when I clicked the link in the email:
tcdailyplanet.us2.list-manage.com/track/click?u=a70a4461b88365762469b4185&id=d5572a6d39&e=940f3597ca
Mac OSX 10.8.2
Mail 6.2 (1499)
Firefox 19.0.2

Note: This only happens with MailChimp newsletters, not from other sources. This only happens in Firefox, not with other browsers.


Actual results:

Firefox launched, new tab opened, totally blank page.


Expected results:

Page loads from site server. 
Following links using Safari causes pages to load as expected. Page links in Safari look like normal URLs: http://www.tcdailyplanet.net/arts/2013/03/15/artists-life-thankless-not-if-you-count-love-well-money
You click the link in the OSX Mail application ?
What happens if you load the link here ? 
http://tcdailyplanet.us2.list-manage.com/track/click?u=a70a4461b88365762469b4185&id=d5572a6d39&e=940f3597ca
(Reporter)

Comment 2

5 years ago
Clicking the link with the browser already open launches the page as intended.

MailChimp says that there is an issue with Ghostery and following links from emails into Firefox. Ghostery is working on a patch. If I turn off Ghostery I can follow links from the MailChimp email just fine.

So maybe you can close this bug? It seems like the problem is not with Firefox proper.
I will mark this report invalid (extension bug)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.