Modernize the entry page for filing a bug by including, keeping, and removing products shown on the enter bug page

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: glob)

Tracking

Production

Details

(Reporter)

Description

5 years ago
When a user selects to file a bug, right now, we list the following products:

- Core
- Firefox
- Thunderbird
- Calendar
- Camino
- SeaMonkey
- Firefox for Android
- Mozilla Localizations
- Mozilla Labs
- Mozilla Services
- Other Products

I think we need to revisit the list here that's shown. There's certain products that are not on that list that I think should be there (e.g. BootToGecko), there's products that should remain on that list (e.g. Firefox), and there's products I don't think are necessary to still be on that list primarily (e.g. Camino). On Monday, I'll open a discussion on this on dev.platform. This bug will track the work to change the front enter bug page to reflect the results of the discussion.
(Assignee)

Comment 1

5 years ago
there's two lists to consider:

users who don't have canconfirm (most users) see the following list:
https://bugzilla.mozilla.org/enter_bug.cgi?format=guided
- Firefox
- Firefox for Android
- Thunderbird
- Mozilla Services
- SeaMonkey
- Mozilla Localizations
- Mozilla Labs
- Calendar
- Core

the list you've provided is for "advanced" users:
https://bugzilla.mozilla.org/enter_bug.cgi?format=__default__

i agree that both of these lists need to be updated.
(Reporter)

Comment 2

5 years ago
I've started the discussion on this here:

https://groups.google.com/forum/#!topic/mozilla.dev.platform/ZPgbRh6UTJ4
(Assignee)

Comment 3

5 years ago
based on the discussion here's my proposal:

guided:

firefox
firefox os [boot2gecko]
firefox for android
firefox for metro
marketplace
thunderbird
seamonkey
core
localisations [mozilla localisations]
services [mozilla services]

standard:

core
firefox
firefox os [boot2gecko]
firefox for android
firefox for metro
toolkit
marketplace
thunderbird
seamonkey
mozilla localisations
mozilla services


we should also emphasise the "Report an issue with Firefox on a site that I've developed" link on the guided page, which leads web developers into the core product.
Assignee: nobody → glob
Component: Administration → General
(Reporter)

Comment 4

5 years ago
That sounds fine to me. I did some bug digging in Bugzilla for comparative analysis along with the discussion conducted and came to a similar conclusion - mine I ended up was as a general list (guided vs. standard not compared here and not ordering):

* Core
* Firefox
* Firefox for Metro
* Firefox for Android
* Firefox OS
* Marketplace
* Thunderbird
* SeaMonkey
* Mozilla Localizations
* Mozilla Services

But what you have above I think works better.

Updated

5 years ago
Duplicate of this bug: 851810
Is there any way we can relabel "Core" as "Gecko" in the guided list? ISTM that web developers are more likely to recognize Gecko than Core as something into which they might file bugs.
(Reporter)

Comment 7

5 years ago
(In reply to Joe Drew (:JOEDREW! \o/) from comment #6)
> Is there any way we can relabel "Core" as "Gecko" in the guided list? ISTM
> that web developers are more likely to recognize Gecko than Core as
> something into which they might file bugs.

I agree. There was some discussion in that thread suggesting this. Core is a confusing naming scheme too for anyone first seeing Bugzilla - when I first started working here, I did not really understand what Core meant until someone explained to me that this was referring to the core of gecko.
I like glob's list and ordering, especially that we offer the most commonly used categories first in the guided list. I also like that we give two names in cases like FirefoxOS [boot2gecko].  

On the guided form, could we make it more clear in some way what top level category a reporter should pick if they have a layout bug? That is a very common problem and stumps people right away (is this Firefox or Core/Gecko or what). Since Core is more than just gecko (as I understand it) maybe we could add [Gecko] on so that it is Core [gecko] .  But that will not clear up a lot of people's confusion about where to start for layout bugs.
(Assignee)

Comment 9

5 years ago
guided already has:
> Report an issue with Firefox on a site that I've developed
which dumps you into core.

the plan is to emphasise this link, which i feel addresses the issue of web developers not knowing that core is the probably the product they want.


note: when i wrote:  "Firefox OS [boot2gecko]" i really meant that the display name will be "firefox os", however this is actually (and silently) the b2g product.

the text next to the product name is the normal product descriptions, so we can quickly make changes to that if required.

eg. core used to have:

> Shared components used by Firefox and other Mozilla software, including handling of
> Web content (HTML, CSS, scripts, images, networking, etc.).

i've just added gecko and layout to this blurb:

> Shared components used by Firefox and other Mozilla software, including handling of
> Web content (Gecko, HTML, CSS, layout, scripts, images, networking, etc.).
(Assignee)

Comment 10

5 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/template/en/default/global/choose-product.html.tmpl
added extensions/BMO/web/core.png
added extensions/BMO/web/marketplace.png
modified extensions/GuidedBugEntry/template/en/default/guided/guided.html.tmpl
modified extensions/GuidedBugEntry/template/en/default/guided/products.html.tmpl
added extensions/GuidedBugEntry/web/images/webbug.png
added extensions/GuidedBugEntry/web/images/products/marketplace.png
modified extensions/GuidedBugEntry/web/js/guided.js
modified extensions/GuidedBugEntry/web/style/guided.css
Committed revision 8674.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

5 years ago
Just curious - when would we see these changes deployed to bugzilla.mozilla.org?
(In reply to Jason Smith [:jsmith] from comment #11)
> Just curious - when would we see these changes deployed to
> bugzilla.mozilla.org?

Hopefully this weeks push so maybe tomorrow.

dkl
If you are including Thunderbird and Seamonkey, I don't understand why Calendar again falls off the table. There has been a history of this happening and as the project suffers from low manpower (read: just me full time, a few others in their free time after work) I think it would be unfair to make it less obvious where to file bugs. This has been the one of few topics that I don't have to write support emails for because people just seem to find the bug reporter. You removing this now will really make my life harder.

I'm happy to reconsider once the webdev team has taken care of the new website, but I really think this is a bad decision for the Mozilla Calendar Project.

Comment 14

5 years ago
I agree with Fallen, Calendar is still an active community project. Why can't it be on the lists right below Thunderbird?  The calendar extension (aka lightning) in thunderbird still has over 1,000,000 users.  I think giving them an easy way to find where to file bugs is useful.
(Assignee)

Comment 15

5 years ago
there are many projects which are under active development but aren't on that list.

people wanting to report calendar bugs will have to click on 'other product' or use the search facility.  as calendar is the third product listed on the 'other products' page it isn't hard to find.
You need to log in before you can comment on or make changes to this bug.