Opening a new window sometimes restores a previously closed window

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: jaws, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Occasionally I have noticed pressing Ctrl+N (to open a new window) is opening a new window with a single tab from a previously closed window.

The basic STR are:
Open a second window and navigate the tab to a different URL
Close the window
Press Ctrl+N to open a new window

Expected:
New blank window

Actual:
Previously closed window is restored.

This is not reproducible 100% of the time, but filing it in case someone else has better STR. I started to notice this a couple days ago in FxNightly 22 on Win7.
Can you reproduce it often enough to find a regression range?
Keywords: regressionwindow-wanted
I can reproduce it but it takes a while to hit it. I also can trigger this by tearing off a tab to make a new window.
Summary: Pressing Ctrl+N to open a new window sometimes restores a previously closed window → Opening a new window sometimes restores a previously closed window

Comment 3

5 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:22.0) Gecko/20130316 Firefox/22.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130411 Firefox/23.0 	

Can you please provide the build ID of the Firefox on which you find the bug?
You can find the build ID, writing "about:support" on the URL bar.

I was unable to reproduce the issue using STR from the description, on Firefox Nightly 22.0(Build ID:20130316030854) and on Firefox latest nightly (Build ID:20130411030925).
I had been seeing this with Nightly builds from before March 16th as well as after.

I haven't seen it in a couple days, and I'm still not sure what causes it to happen. I'll close the bug until I see it again. (Also hoping for some better STR to reveal themselves.)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
I just saw this again on the 4-19 Firefox Nightly build on Win7.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Now that I think of it, Ctrl+N (open new window) and Ctrl+Shift+N (restore previously closed window) are very close in keyboard distance, and it is possible that I am bumping the shift key when trying to hit Ctrl+N.

I'll keep this bug closed until I can find reliable STR.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.