If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser tries to open PHP Files from the cache (that were never cached) when restarted.

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
5 years ago
4 years ago

People

(Reporter: Rob, Unassigned)

Tracking

21 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 725863 [details]
Screenshot of Popups showing inability to open cached ".php.part" file (that was never cached).

When restarting Aurora (and I use TM+) the Tabs will reload but sometimes the Browser will try to open PHP Files, both without the Browser's Popup asking if you want to save them AND at other times it does offer to let you save them.


THIS Bug Report is about the reloading of Temporary Files (from the User's Hard Drive, not a remote Server) that are ".php.part" type Files. It would seem from the Popup that the File was never cached in the first place, and so it could not be reopened (if that were desired); because it is a ".php.part" File it can not be opened in any event (and so there is no "Browser Popup" offering to "Save the File", only a Popup saying the (uncached File) can not be read (from the cache?)).

It seems (based on the File Name, in this example) to have something to do with a "Like Button" on the Web Page. I have also seen it occur with other files (not derived from a "Like Button").


A similar (but not identical Bug, since that involves someone else's Server, and this BR involves Files cached on the User's Hard Drive) is Bug 336419 (which was resolved invalid).


The Browser's action causes multiple Popups on the User's Screen.

Enclosed is a Screenshot showing two Popups.

Comment 1

5 years ago
Did you try with a fresh profile (don't import anything) by browsing a few websites then restarting Firefox?
Flags: needinfo?(rob1weld)
(Reporter)

Comment 2

5 years ago
(In reply to Loic from comment #1)
> Did you try with a fresh profile (don't import anything) by browsing a few
> websites then restarting Firefox?

There needs something cached for there to be something read from the cache.

Last time I used the Profiles there was a Bug that no one was fixing, it deleted my work so I've stayed away from them.
Flags: needinfo?(rob1weld)

Comment 3

5 years ago
Just create a new profile, visit some websites with php files, then restart FF with this new profile. It's pretty easy.

Comment 4

5 years ago
I think this should be moved to "General" component.
(Reporter)

Comment 5

5 years ago
Answered in Comment 2.

(In reply to Mitza from comment #4)
> I think this should be moved to "General" component.

Last time I put something in General I was told it had to go to a different Category.

I chose Untriaged since it's Description is: "For newly filed bugs that need some help finding the right place to go.". It could also go to "Downloads Panel" (assuming the 'Download Popup' and associated cached Page Message fall into that Category), or "Session Restore" (assuming it is not caused by the Plugin), or "File Handling" (since we should not fail on our own cached files).
(In reply to Loic from comment #3)
> Just create a new profile, visit some websites with php files, then restart
> FF with this new profile. It's pretty easy.
Flags: needinfo?(rob1weld)
Whiteboard: [closeme 2013-08-15]

Comment 7

4 years ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rob1weld)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2013-08-15]
You need to log in before you can comment on or make changes to this bug.