Window size is lost when a tab is detached if window is maximized and has one tab

RESOLVED DUPLICATE of bug 675401

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 675401
5 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

7 Branch
x86_64
All
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/0b052daa913c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130317 Firefox/22.0 ID:20130317030923

Steps to Reproduce:
1. Open only one tab
2. Maximize Browser
3. Drag the tab to downward and drop

Actual Results:
Window becomes normal mode, And the size of window is almost maximized size in Windows.
And previous size of normal mode is lost.

Expected Results:
Window should keep their size and mode.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/fb1291a31b54
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110704 Firefox/7.0a1 ID:20110704034927
Bad:
http://hg.mozilla.org/mozilla-central/rev/29bc151be813
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0a1) Gecko/20110704 Firefox/7.0a1 ID:20110704053612
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fb1291a31b54&tochange=29bc151be813

Triggered by:
	fa4005b29b5e	Jezreel Ng — Bug 465186 - When detaching a tab, open the new window at the drop location.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 675401
You need to log in before you can comment on or make changes to this bug.