Update Google search engine icon

RESOLVED FIXED in Firefox 22

Status

()

Firefox
Theme
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: fryn, Assigned: fryn)

Tracking

Trunk
Firefox 22
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 725919 [details] [diff] [review]
patch

Our Google search engine icon is outdated.

Spun this off from bug 848150, because switching from a 16×16 to a 32×32 icon caused mochitest-bc to fail almost every time exclusively on linux64 opt & pgo, and it fails near the beginning of the first mochitest-bc test:
chrome://mochitests/content/browser/browser/base/content/test/browser_CTPScriptPlugin.js
logging the following TEST-UNEXPECTED-FAIL:
should have a click-to-play notification (about:blank)
instead of the following TEST-PASS:
should have a click-to-play notification (plugin_test_noScriptNoPopup.html)
Attachment #725919 - Flags: ui-review+
Attachment #725919 - Flags: review+
(Assignee)

Updated

5 years ago
Blocks: 795495
(Assignee)

Comment 1

5 years ago
Try run:
https://tbpl.mozilla.org/?tree=Try&rev=028ca992f8db
(Assignee)

Comment 2

5 years ago
Created attachment 727504 [details]
screenshot of test failure

This is a screenshot of the test failure.
Absolutely nothing looks wrong, except that the intended test page didn't load.
The Google search engine icon looks fine.
Frank, these symptoms sound similar to the issue that was causing bug 851516. Can you try again now that bug 851516 has been fixed?
Flags: needinfo?(fyan)
(In reply to Jared Wein [:jaws] from comment #3)
> Frank, these symptoms sound similar to the issue that was causing bug
> 851516. Can you try again now that bug 851516 has been fixed?

That sounds exactly like what I saw last night when I was debugging this.  I was going to file the same bug so thanks for saving my time. :)  I'll double-check the fix in a bit.
(Assignee)

Comment 5

5 years ago
(In reply to Matthew N. [:MattN] from comment #4)
> (In reply to Jared Wein [:jaws] from comment #3)
> > Frank, these symptoms sound similar to the issue that was causing bug
> > 851516. Can you try again now that bug 851516 has been fixed?
> 
> That sounds exactly like what I saw last night when I was debugging this.  I
> was going to file the same bug so thanks for saving my time. :)  I'll
> double-check the fix in a bit.

Thanks for your help, guys. :) Just pushed a new try run here:
https://tbpl.mozilla.org/?tree=Try&rev=b360434104f9
Flags: needinfo?(fyan)
(Assignee)

Comment 6

5 years ago
After five consecutive linux64 mochitest-bc test passes, this looks good to land now.

Landed!
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb82ad6cfd67

Now, we have the right shade of blue in our Google search engine icon, and, as a bonus, every Firefox-provided image in our default primary UI supports HiDPI on OS X.
Target Milestone: --- → Firefox 22
(Assignee)

Updated

5 years ago
Attachment #725919 - Attachment description: patch (not ready due to linux64 opt mochitest-bc failure) → patch
(Assignee)

Updated

5 years ago
Attachment #727504 - Attachment is obsolete: true

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/bb82ad6cfd67
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.