seamonkey 2.16.2 email refuses to open new message

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: andr55, Unassigned)

Tracking

SeaMonkey 2.16 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15.2
Build ID: 20130203000123

Steps to reproduce:

case 1) attempted to reply to a email
case 2) attempted to create a new email

Both on a POP3 account.


Actual results:

In both cases, received a message that it wasn't possible now, to try again later.
A few hours later I received the same message.
This message didn't make any sense, as opening a new message is entirely local.

Note that had just upgraded from 2.15.2. which worked correctly.
Reverted to 2.15.2 just after my last test of 2.16.2 (with same error message), and 2.15.2 still worked correctly (just a few minutes after reverting).


Expected results:

Should have opened a new email.
(In case 1, it would have contained the email being replied to)

Comment 1

6 years ago
What was the exact error message you received?

Anything here http://kb.mozillazine.org/Connection_errors_-_SMTP ?
Or Bug 780124 ?
(Reporter)

Comment 2

6 years ago
The message was in French, approximately, translated into English,
"This action is not possible at this time, please try again later".
It took some time to reactivate version 2.15.2  (with the verification of plugins), which I did before the report, to ensure that it was indeed a problem with version 2.16.2.
Not having recorded the exact message, I assumed that any user of Linux (preferably 64 bit) could verify the problem.
If necessary, I could go through the activation process twice again to obtain the exact message.

As I was not able to create a new message (either directly or by responding to another), the mozillazine article on connexion errors should not apply.
Creating a message should not require being on line.
Similarly for bug 780124.
If for some reason 2.16.2 requires being on line in order to create a new message, that is unquestionably an important bug.
I was able to receive messages without problem, and each incoming (pop3) server corresponds to a unique smtp server.  The corresponding servers require the same password.

Note that, with the same configuration, including the same plugins active (except for the version of included plugins), version 2.15.2 works perfectly.
This was verified immediately after reverting to 2.15.2.

Also note that for Linux versions, Seamonkey is installed by decompressing into an arbitrary folder.
So one starts with exactly the layout distributed, adding only plugins installed in the user's profile.
(Reporter)

Comment 3

6 years ago
The exact message that I get is :
"Erreur lors de l'ouverture de la fenêtre de rédaction de messages. Veuillez essayer à nouveau."
which translates to english as :
"Error when opening the window to edit messages.  Please try again."
or "Error when opening the message editor window.  Please try again."
(I don't have an english version.)

This error message occurs if attempting :
1) to open a new message directly (the create new message button), or
2) to open a reply to an existing message (the reply to message button).
Whether on line or off line.

There is no chance to send a message, as one can't access the message editor from which it is possible to send.
Only in version 2.16.2
Version 2.15.2 and before work without problem.

This comment is being posted from version 2.16.2.  The navigator part works normally.
Downloading and viewing existing email works normally as well.
It is just opening the message editor to create and/or send email that is problematic.
Trying to open a message already in the draft box gives the same error message as well.

Running from the console displays no error or warning in the console.

Comment 4

6 years ago
Do you have any add-ons (plugins or extensions) installed?
If so, What are they?
Also could you try starting in safe mode which disables all the add-ons and see if you still have the same problem?
If this works then start in normal mode and disable each add-on (extension or plugin) until you find the one that causes the issue (some might require a restart to properly disable).
(Reporter)

Comment 5

6 years ago
I found and solved the problem.
Using -safe-mode, everything worked fine.
I then found it was due to the virtual-identity extension : I didn't have the most recent version installed.

The most recent version of virtual-identity fixes it, available at
https://www.absorb.it/virtual-id

(The updates are no longer available from addons.mozilla.org )
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.