[email] ActiveSync mimetype-guessing fails for files with non-lowercase extensions (e.g. foo.PNG)

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: squib)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #420218 +++
 
 DEFECT DESCRIPTION:
 'Hotmail' exchange account does not support attachments with capital expanded-name
 
 REPRODUCING PROCEDURES:
 1.Create 'Hotmail' exchange account;
 2.Receive attachment with capital expanded-name;
 3.It has no way to download the attachment-->ko
 PS:IMAP accounts can download and view these attachments 
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:
 Firefox os  v1.0.1
 Mozilla build ID: 20130304070202.
 ++++++++++ end of initial bug #420218 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
Duplicate of this bug: 852001

Comment 2

5 years ago
Can you please provide an example file attachment that runs into this bug?
Flags: needinfo?(sync-1)
(Reporter)

Comment 3

5 years ago
Created an attachment (id=373333)
 test file with capital expanded-name
Flags: needinfo?(sync-1)
(Reporter)

Comment 4

5 years ago
Created attachment 728874 [details]
test file with capital expanded-name

Created an attachment (id=373333)
 test file with capital expanded-name
The most useful thing for determining the cause of the problem would be to have the source of the e-mail message, rather than the attachment.

If you could view the message in the hotmail/outlook.com web UI, then click on the ellipsis ("...") and select "View message source", a new window will be opened with the raw MIME source of the message.

In this window, you should fine one or more portions of text that look like so:
------mailcomposer-?=_1-1352251073171
Content-Type: image/png; name="tb-logo.png"
Content-Disposition: attachment; filename="tb-logo.png"
Content-Transfer-Encoding: base64

iVBORw0KGgoAAAANSUhEUgAAAI8AAACeCAYAAAAL6VmtAAByAklEQVR4XuyWbWxVZx3Af895uS9t


These describe the attachment.  If you could copy and paste the contents of the message from the part dividing line (starts with dashes) through the first line of the encoded body content (which is the first line after a newline), that would be extremely helpful.  Thanks!

Updated

5 years ago
Assignee: nobody → bugmail
Flags: needinfo?(sync-1)
(Reporter)

Comment 6

5 years ago
Dears,
 The reproduce steps is as follows:
 1.Create an hotmail exchange account;
 2.Use another account to send an attachment to the exchange account;the
 expanded-name of the attachment should be captical,such as 123.PNG,123.JPEG,not
 123.png or 123.jpeg;
 3.Exchange account receive the mail,and find that there is no \"View\" option to
 view the attachment.
Flags: needinfo?(sync-1)
(Assignee)

Comment 7

5 years ago
Updating bug summary to be clearer and taking this. It's a one-line fix.
Assignee: bugmail → squibblyflabbetydoo
Status: NEW → ASSIGNED
Summary: [Buri][Email]'Hotmail' exchange account does not support attachments with capital expanded-name → [email] ActiveSync mimetype-guessing fails for files with non-lowercase extensions (e.g. foo.PNG)
(Assignee)

Comment 8

5 years ago
PR up: https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/187
(Assignee)

Comment 9

5 years ago
Landed on Gaia: https://github.com/mozilla-b2g/gaia/pull/9391
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.