Allow developers to opt-in noautofocus for panels

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Assigned: timdream)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Panel will be more useful if add-ons could opt-in "noautofocus" for the xulPanel element.

Use case: a keyboard interactive add-on that show info on the panel as the users types, e.g. the Asian IME [1] I am working on.

I have a verified setting |xulPanel.setAttribute("noautofocus","true");| works -- will figuring out how to wrap that into options and submit a pull request.

[1] https://github.com/timdream/jszhuyin-firefox
BTW, "noatuofocus" should be opt-in because it could break accessibility for usual add-ons. For a usual popup, users certainly would like to <tab> through the controls within when the popup is shown.
Created attachment 726013 [details]
Github: https://github.com/mozilla/addon-sdk/pull/867

Hi Irakli, I am not sure who I should set the review to, can you help :) Thanks.

Code + docs + tests ready.
Attachment #726013 - Flags: review?(rFobic)

Updated

5 years ago
Attachment #726013 - Attachment filename: file_852023.txt → file_852023.html
Attachment #726013 - Attachment mime type: text/plain → text/html
Comment on attachment 726013 [details]
Github: https://github.com/mozilla/addon-sdk/pull/867

Thanks this patch is awesome!!! I'm rejecting it for a minor things I'd love to be addressed before landing it. Please see more details in actual pull request.
Attachment #726013 - Flags: review?(rFobic) → review-
Comment on attachment 726013 [details]
Github: https://github.com/mozilla/addon-sdk/pull/867

Review comment addressed, re-request for review again.
Attachment #726013 - Flags: review- → review?(rFobic)
Attachment #726013 - Flags: review?(rFobic) → review?(zer0)

Comment 5

5 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/e797b3a867b8fa3b46819672ef7addae277de327
Bug 852023 - Allow developers to opt-in noautofocus for panels

https://github.com/mozilla/addon-sdk/commit/137030e3fe610cd0cb9bf3284de3e95f56c4b20c
Merge pull request #867 from timdream/panel-noautofocus

fix Bug 852023 - Allow developers to opt-in noautofocus for panels r=@ZER0

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #726013 - Flags: review?(zer0) → review+
Duplicate of this bug: 857958
You need to log in before you can comment on or make changes to this bug.