Incorrect/partial downloading of attachment

VERIFIED DUPLICATE of bug 67493

Status

SeaMonkey
MailNews: Message Display
VERIFIED DUPLICATE of bug 67493
17 years ago
13 years ago

People

(Reporter: Chris P. Ross, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This looks a lot like bug 79517, but that's marked as resolved in 0.9 (will
bugzilla let me reopen a bug?)

I'm running 0.9.1 on MacOS 9.1 (Build ID 2001060712)
I have an attachment that's an approximately 30 kb Word document (which is
sadly marked as application/octet-stream in the MIME headers).  When I
try to save it to my local disk (from the SSL IMAP server connection I'm
reading mail from), the save dialog appears and it creates a file.  But,
that file is only 27 bytes long.  If I open that same message on the same
server with Communicator 4.76, I can save the whole attachment just fine.

I don't know that this isn't related to bug 85203, which I also reported
today, about truncating the names of attachments that include spaces in 
their names.
(Reporter)

Comment 1

17 years ago
New information:  Related to bug 85203 (now closed).

The program that sent the message with the attachments having
this problem also did not properly construct the MIME headers,
causing the problem noted in 85203 (which is not a mozilla bug)

The file (a Word doc) was sent to me from another program,
which correctly Content-Type'd it as application/msword,
and I can download that successfully.  So, either the program
that constructed the original message did something odd,
(but Communicator dealt with it) or mozilla's bug is
related to it being a application/octet-stream attachment.
FYI.

Comment 2

17 years ago
I believe this bug duplicates 67493. Please see my comments on that bug.

*** This bug has been marked as a duplicate of 67493 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.