Playing HTML5 games in Firefox is impossible because of the quickfind feature

RESOLVED INVALID

Status

()

Firefox
Keyboard Navigation
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: st3ed, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-03-25] INVALID?)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22

Steps to reproduce:

Try to play a HTML5 game in Firefox with the keyboard.


Actual results:

Quickfind opened, rendering it impossible to play the game.


Expected results:

I should have been able to play the game without interruption from the browser.

Comment 1

5 years ago
options > advanced > general > uncheck "Search for text when i start typing"
(Reporter)

Comment 2

5 years ago
What's the default behaviour?

I'm reporting this because we had a dismal playtest of an array of HTML5 games. None of the developers had ever considered Firefox quicksearch so every time we had to drop out and use Chrome. Plus there was no transparent way to disable the feature - hidden in options? No one thought of that, we just kept hitting this road block and thought - "this browser is defective, load up Chrome".

I've not got quicksearch checked on in my version of Firefox so I'm unsure if it's on by default.

Certainly any user that wanted to make use of quicksearch might enjoy the ability to disable it just for that page - otherwise HTML5 gamers require reconfiguring their options, forgetting about them, and then being annoyed that they forgot to turn them back on again.

The games were for the 7DRL Challenge: http://7drl.org
Many of them were written in javascript.

This can be put down as a usability issue instead of a bug. Thanks for the instructions on disabling the feature.

Comment 3

5 years ago
its unchecked by default
(Reporter)

Comment 4

5 years ago
Interesting... That's now how our host was behaving in regards to his browser.

I'll set him straight. Thanks.

Updated

5 years ago
Whiteboard: INVALID?

Updated

5 years ago
Whiteboard: INVALID? → [closeme 2013-03-25] INVALID?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Keyboard Navigation
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.