Cleanup and fix various console warnings in Metro front end

RESOLVED FIXED in Firefox 22

Status

Firefox for Metro
Browser
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

Trunk
Firefox 22
x86_64
Windows 8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Fix various console warnings in Metro front end.
- Remove pointless calls in grid.xml this.setColor(); and this.setBackgrounImage
- Returning this._color before it is defined in grid.xml
- Bookmarks.js aIconUri is null errors
- input.js trying to assign getter (see browser-scripts.js for the cause)
- browser-uis.js mytyped assignment warning fix
- InputSourceHelper remove pointless properties
(Assignee)

Updated

5 years ago
Summary: Fix various console warnings in Metro front end → Cleanup and fix various console warnings in Metro front end
(Assignee)

Comment 1

5 years ago
Created attachment 726224 [details] [diff] [review]
Patch v1.
Assignee: nobody → netzen
Attachment #726224 - Flags: review?(mbrubeck)
Attachment #726224 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/121c90c4ebe4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 854011
You need to log in before you can comment on or make changes to this bug.