Last Comment Bug 852295 - LW Themes do not display in Permanent Private Browsing mode post Per-Window PB
: LW Themes do not display in Permanent Private Browsing mode post Per-Window PB
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: General (show other bugs)
: unspecified
: All All
: -- minor with 1 vote (vote)
: mozilla22
Assigned To: :Cykesiopka
: Ioana (away)
:
Mentors:
: 853426 857624 859150 861056 861527 861666 (view as bug list)
Depends on:
Blocks: 749394
  Show dependency treegraph
 
Reported: 2013-03-18 14:48 PDT by :Cykesiopka
Modified: 2013-08-26 13:23 PDT (History)
16 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
verified
verified
verified


Attachments
Proposed Patch v0 (1.85 KB, patch)
2013-03-18 14:50 PDT, :Cykesiopka
dao+bmo: review+
akeybl: approval‑mozilla‑beta+
lukasblakk+bugs: approval‑mozilla‑release-
Details | Diff | Splinter Review
Personas (1.90 KB, patch)
2013-04-20 00:38 PDT, Chris
no flags Details | Diff | Splinter Review

Description :Cykesiopka 2013-03-18 14:48:27 PDT
Pre Per-Window PB, Lightweight Themes would display even in permanent private browsing mode.

Post Per-Window PB, LW Themes only display in normal tabs, with permanent private browsing mode off.

IMO the previous behaviour is preferable, as there is no need to differentiate tabs when they are all private tabs.
Comment 1 :Cykesiopka 2013-03-18 14:50:31 PDT
Created attachment 726348 [details] [diff] [review]
Proposed Patch v0

And a patch that seems to work on Linux64. Not sure if this will break any tests however...
Comment 2 :Cykesiopka 2013-03-28 22:22:10 PDT
Feedback ping?
Comment 3 Josh Matthews [:jdm] (on vacation until Dec 5) 2013-03-29 05:49:21 PDT
*** Bug 854126 has been marked as a duplicate of this bug. ***
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-03-29 08:32:01 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/645f32d5e266
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-03-30 17:56:35 PDT
https://hg.mozilla.org/mozilla-central/rev/645f32d5e266
Comment 6 Joshua Smith [:joshua-s] 2013-04-05 16:37:10 PDT
This is really in demand, see: https://support.mozilla.org/en-US/questions/955230.

Is there any way we could move this to an earlier milestone?
Comment 7 Dão Gottwald [:dao] 2013-04-06 04:06:34 PDT
Comment on attachment 726348 [details] [diff] [review]
Proposed Patch v0

[Approval Request Comment]
Regression caused by (bug #): bug 749394
User impact if declined: Lightweight themes don't work in permanent private browsing mode
Testing completed (on m-c, etc.): on m-c during the 22 cycle
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Comment 8 Christian Ascheberg 2013-04-06 04:51:32 PDT
(In reply to Joshua Smith [:joshua-s] from comment #6)
> This is really in demand, see:
> https://support.mozilla.org/en-US/questions/955230.
> 
> Is there any way we could move this to an earlier milestone?

It seems like most complaints are about regular private browsing windows. This patch only fixes lightweight themes in *permanent* PB mode though.
Note that it is probably not a problem to enable lightweight themes for users on Windows, see duplicate bug 854126 comment 5. Maybe you could add a check for that case, too.
Comment 9 Josh Matthews [:jdm] (on vacation until Dec 5) 2013-04-07 14:50:50 PDT
*** Bug 859150 has been marked as a duplicate of this bug. ***
Comment 10 Lukas Blakk [:lsblakk] use ?needinfo 2013-04-08 15:27:32 PDT
Comment on attachment 726348 [details] [diff] [review]
Proposed Patch v0

This isn't something we'd take in a dot release as a ridealong without testing on beta first.
Comment 11 Alex Keybl [:akeybl] 2013-04-10 13:01:45 PDT
The verifyme is for FF21 specifically.
Comment 13 Josh Matthews [:jdm] (on vacation until Dec 5) 2013-04-11 06:53:30 PDT
*** Bug 857624 has been marked as a duplicate of this bug. ***
Comment 14 Christian Ascheberg 2013-04-11 09:36:40 PDT
*** Bug 853426 has been marked as a duplicate of this bug. ***
Comment 15 Loic 2013-04-11 09:51:10 PDT
*** Bug 860803 has been marked as a duplicate of this bug. ***
Comment 16 Paul Silaghi, QA [:pauly] 2013-04-12 06:43:39 PDT
*** Bug 861056 has been marked as a duplicate of this bug. ***
Comment 17 Paul Silaghi, QA [:pauly] 2013-04-15 06:25:25 PDT
*** Bug 861527 has been marked as a duplicate of this bug. ***
Comment 18 Ioana (away) 2013-04-17 02:33:23 PDT
Verified as fixed on Windows 7 64bit, Ubuntu 12.10 32bit and Mac OSX 10.7.5 with Firefox 21 beta 3 (20130416200523).

LW themes are now also applied in permanent PB mode.
Comment 19 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-04-17 11:15:02 PDT
(In reply to Ioana Budnar [QA] from comment #18)
> Verified as fixed on Windows 7 64bit, Ubuntu 12.10 32bit and Mac OSX 10.7.5
> with Firefox 21 beta 3 (20130416200523).
> 
> LW themes are now also applied in permanent PB mode.

Thanks Ioana. Can you please verify this against the latest Aurora and Nightly builds when you get a chance?
Comment 20 Ioana (away) 2013-04-18 04:52:51 PDT
Verified as fixed on the 04/17 Aurora and Nightly builds - Win7 64bit, Ubuntu 12.10 32bit and Mac OSX 10.8.3 64bit.
Comment 21 Chris 2013-04-20 00:38:53 PDT
Created attachment 739936 [details] [diff] [review]
Personas
Comment 22 :Cykesiopka 2013-06-09 11:56:13 PDT
*** Bug 861666 has been marked as a duplicate of this bug. ***
Comment 23 bahamut00 2013-08-25 14:03:44 PDT
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #12)
> https://hg.mozilla.org/releases/mozilla-beta/rev/1422a858262d

Well, it seems that the fix has not reached FF 23.0 under Linux (Fedora 18): personas are still disabled in what you call "regular" private windows.
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-08-26 11:45:15 PDT
(In reply to bahamut00 from comment #23)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #12)
> > https://hg.mozilla.org/releases/mozilla-beta/rev/1422a858262d
> 
> Well, it seems that the fix has not reached FF 23.0 under Linux (Fedora 18):
> personas are still disabled in what you call "regular" private windows.

This landed in Firefox 21, 22, and 23, and was verified to be working. If you are having an issue in the latest release please file a new bug and mark it as dependent on this bug.
Comment 25 Josh Matthews [:jdm] (on vacation until Dec 5) 2013-08-26 13:23:21 PDT
Note that regular private windows were not intended to be affected by this change. Only file a new issue if lightweight themes are not showing up when Never Remember History is enabled.

Note You need to log in before you can comment on or make changes to this bug.