Closed Bug 852400 Opened 7 years ago Closed 7 years ago

[tara]touch screen can't respond

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: james.zhang, Assigned: james.zhang)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/11.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19

Steps to reproduce:

press the tara's touch screen


Actual results:

touch screen can't respond


Expected results:

touch screen should respond user press
Attached patch fix touch screen can't respond (obsolete) — Splinter Review
Hi! Michael,

Could you help on this bug from our partner?
They are new to bugzilla.
Thanks.

--
Keven
Assignee: nobody → mwu
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Depends on: 739417
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 726485 [details] [diff] [review]
fix touch screen can't respond

Review of attachment 726485 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch. Can you submit a patch that removes this code entirely? This was put here for compatibility with Gingerbread, but we don't support that anymore so we can just remove this code.
(In reply to Michael Wu [:mwu] from comment #3)
> Comment on attachment 726485 [details] [diff] [review]
> fix touch screen can't respond
> 
> Review of attachment 726485 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks for the patch. Can you submit a patch that removes this code
> entirely? This was put here for compatibility with Gingerbread, but we don't
> support that anymore so we can just remove this code.

Done.
Attachment #737078 - Flags: review+
Attachment #726485 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/f5f730869f6a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
CC'ing leo since there may be compatibility issues here.
After checking the touch panel event in Leo, I found there's no following event reported when finger leaving and it looks like the finger never leaves.
0000 0002 00000000
0000 0000 00000000

Do that events reported same as our expection in Leo?
Shall same event will treat as finger leave in Android platform?
Flags: needinfo?(leo.bugzilla.gecko)
The following log shows touch 'click' event.
What you said "0002, 0000" are associated with EV_SYN and these would pass through driver to framwork(gecko) layer.
This is normal process and same with Android platform.


0003 0039 00000000 : EV_ABS       ABS_MT_TRACKING_ID   00000000
0003 0035 00000090 : EV_ABS       ABS_MT_POSITION_X    00000090
0003 0036 0000013e : EV_ABS       ABS_MT_POSITION_Y    0000013e
0003 0030 0000000a : EV_ABS       ABS_MT_TOUCH_MAJOR   0000000a
0003 0032 00000008 : EV_ABS       ABS_MT_WIDTH_MAJOR   00000008
0000 0002 00000000 : EV_SYN       SYN_MT_REPORT        00000000
0000 0000 00000000 : EV_SYN       SYN_REPORT           00000000
0003 0039 00000000 : EV_ABS       ABS_MT_TRACKING_ID   00000000
0003 0035 00000090 : EV_ABS       ABS_MT_POSITION_X    00000090
0003 0036 0000013e : EV_ABS       ABS_MT_POSITION_Y    0000013e
0003 0030 00000000 : EV_ABS       ABS_MT_TOUCH_MAJOR   00000000
0003 0032 00000000 : EV_ABS       ABS_MT_WIDTH_MAJOR   00000000
0000 0002 00000000 : EV_SYN       SYN_MT_REPORT        00000000
0000 0000 00000000 : EV_SYN       SYN_REPORT           00000000
Sorry for the late response.

The touch event stream you posted is actually the old style. In this type, a touch end (finger lifted) is indicated by sending the same touch point again with a ABS_MT_TOUCH_MAJOR of 0 (type B). This was supported in in Gingerbread, but in ICS, the input reading code requires the touch data to be omitted when the finger is lifted (type A). We use the ICS input reader code, so we have the same type A requirement.

See kernel/Documentation/input/multi-touch-protocol.txt for more details.

BTW, there should be a fixed melfas driver available. The Galaxy S2 on Gingerbread used type B melfas touch drivers, but Galaxy S2 on ICS uses type A melfas touch drivers.
Flags: needinfo?(leo.bugzilla.gecko)
Blocks: 887486
You need to log in before you can comment on or make changes to this bug.