Strres shall support more robust fallback scheme

VERIFIED DUPLICATE of bug 8188

Status

()

Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 8188
18 years ago
18 years ago

People

(Reporter: tao, Assigned: tao)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
There is no fallback mechanism in the current implementation. I have patches
in my tree to enable a simple, "lang_country" -> "lang" -> "", fallback.

However, we may want to consider a little more sophiscated scheme such as
"user's locale" -> "default application locale" -> "none" type fallback. For
example, The strres class is provided with "fr_CA" and the application locale
is "en-US", then the fallback path will be

 fr_CA -> fr -> en_US -> en -> none
(Assignee)

Updated

18 years ago
QA Contact: teruko → tao
Target Milestone: M8
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
QA Contact: tao → teruko
(Assignee)

Comment 1

18 years ago
I had checked in a patch to perform the "fr_CA ->fr->none" part of the
fallback.

See bug

	http://bugzilla.mozilla.org/show_bug.cgi?id=8188


for details.
(Assignee)

Updated

18 years ago
Target Milestone: M8 → M9
(Assignee)

Comment 2

18 years ago
This is not a M8 show stopper. We need more discussion on how the mechanism
shall work.
(Assignee)

Updated

18 years ago
Target Milestone: M9 → M11
(Assignee)

Comment 3

18 years ago
non show stopper-> M11
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Target Milestone: M11 → M10
(Assignee)

Comment 4

18 years ago
We'll embed the locale name in the URL path instead of filename. See bug 8188.

*** This bug has been marked as a duplicate of 8188 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
verified dup
You need to log in before you can comment on or make changes to this bug.