Incomplete graphics download not being displayed

RESOLVED INVALID

Status

()

Core
Layout
--
minor
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Gordon Ross, Assigned: asa)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

When Mozilla fails to complete downloading a graphic, mozilla shows nothing, and
reflows the page as if the graphic doesn't exist

Reproducible: Sometimes
Steps to Reproduce:
1.Goto a graphical intensive page over a slow link
2.Watch Mozilla attempt to download the graphics, and fail


Actual Results:  Mozilla re-flows the page as if the graphics don't exist

Expected Results:  Mozilla should display the page correctly, even if it can't
download the page

The problem also occurs if you start downloading a page and click on a link
before the page has completed downloading. Mozilla reflows the page ignoring the
"missing" bits. This can be confusing 'cause you can click on a link, and
Mozilla will reflow the page changing the link under the mouse.

Comment 2

17 years ago
p1-4: nope, this is just not a bug. there are places where we describe this in 
bugzilla. if you use:

<img alt="you should never see this unless the image does not load" title="you 
should see this when you :hover" src="data:">

then you will get from mozilla the correct behavior (namely the alt text will 
appear in the document).

NavQuirks may or may not do something differently, but it's the page authors 
fault for not including an alt tag which has been a REQUIRED part of html for 
years.

Erm actually, the reporter managed to report a few duplicates.
p5 is a dupe of mozilla should load the page before it downloads [it's an easy 
bug to find]
p6 is a dupe of some reflow behavior which is probably not a bug.
please search bugzilla and you will find the issues you've described.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: Browser-General → Layout
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.