Intermittent B2G emulator Marionette test_incoming_multipart.js | TimeoutException: socket.timeout

RESOLVED WORKSFORME

Status

Firefox OS
RIL
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

unspecified
ARM
Gonk (Firefox OS)
intermittent-failure
Dependency tree / graph

Firefox Tracking Flags

(b2g18-)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20834959&tree=Mozilla-Inbound

b2g_ics_armv7a_gecko_emulator_vm mozilla-inbound opt test marionette-webapi on 2013-03-19 10:55:51 PDT for push 008214fd37cf
slave: tst-linux64-ec2-042

11:07:38     INFO -  TEST-START test_incoming_multipart.js
11:10:39     INFO -  /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_incoming_multipart.js, runTest (marionette_test.MarionetteJSTestCase) ... ERROR
11:10:39     INFO -  ======================================================================
11:10:39     INFO -  ERROR: /builds/slave/test/build/tests/marionette/tests/dom/mobilemessage/tests/marionette/test_incoming_multipart.js, runTest (marionette_test.MarionetteJSTestCase)
11:10:39     INFO -  ----------------------------------------------------------------------
11:10:39     INFO -  Traceback (most recent call last):
11:10:39     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 242, in runTest
11:10:39     INFO -      self.marionette.execute_script("log('TEST-END: %s');" % self.jsFile.replace('\\', '\\\\'))
11:10:39     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 541, in execute_script
11:10:39     INFO -      scriptTimeout=script_timeout)
11:10:39     INFO -    File "/builds/slave/test/build/tests/marionette/marionette/marionette.py", line 289, in _send_message
11:10:39    ERROR -      raise TimeoutException(message='socket.timeout', status=ErrorCodes.TIMEOUT, stacktrace=None)
11:10:39    ERROR -  TEST-UNEXPECTED-FAIL | test_incoming_multipart.js | TimeoutException: socket.timeout
11:10:39     INFO -  ----------------------------------------------------------------------
11:10:39     INFO -  Ran 1 test in 181.330s
11:10:39  WARNING -  FAILED (errors=1)

Updated

5 years ago
Keywords: intermittent-failure
tracking-b2g18: ? → -
Blocks: 859417
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Component: Gaia::SMS → RIL
Try looks good: https://tbpl.mozilla.org/?tree=Try&rev=56457b9a727f

although this try includes Bug 901457. Maybe land it will also fix this.

Anyway, I cannot reproduce this bug.
That's what's fun with intermittents: they don't show up always ;)

This one is especially intermittent: only 3 occurences since March.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.