[Call]Accept one call while hold on another call, the 3rd call will be Rejected

RESOLVED DUPLICATE of bug 853768

Status

Firefox OS
Gaia::Dialer
RESOLVED DUPLICATE of bug 853768
5 years ago
5 years ago

People

(Reporter: xiaohui, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

383.76 KB, text/plain
Details
2.81 MB, application/octet-stream
Details
(Reporter)

Description

5 years ago
Created attachment 727032 [details]
call_multi.log

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.3)

Steps to reproduce:

This issue happens when phone has a communication with two calls, one active
and one hold, if the 3rd incomming call occurs and it is accepted, phone should
release the active call and answer the incomming.
problem is the 3rd incomming call is forwarded to voice mail, phone does not show
any alert of the new incoming call.



Actual results:

The 3rd incomming call is forwarded to voice mail, phone does not show
any alert of the new incoming call:

I/Gecko   (  140): -*- QCContentHelper_QC_B2G: sendMessage to content process:
RIL:CallStateChanged{  state : 11,callIndex : 3,toa : 129,isMpty : false, isMT
: true, als : 0, isVoice: true, isVoicePrivacy: false, number :
'18621657907',numberPresentation : 0,name: '', namePresentation : 0, uusInfo:
null, isActive : false}
I/Gecko   (  140): -*- QCContentHelper_QC_B2G: Notify system message manager of
telephony-new-call
D/CALL_TRACKER_QC_B2G(  140): Phone state is RINGING
D/CALL_TRACKER_QC_B2G(  140): updateWakeState: keepScreenOn = 1 (isRinging 1,
isDialing 0)
D/PHONE_QC_B2G(  140): SetAudioMode() for phone state RINGING
I/Gecko   (  140): -*- QCContentHelper_QC_B2G: receiveMessage: 'RIL:RejectCall'
arrived from content process




Expected results:

Beetle Lite FF = phone A
Other phones = phone B, C, D

Phone A receive a call from B
Phone A answer the call from B
Phone C calls to A
Phone A notify user there is an incoming call 
Phone A answer the call from C, 
Phone A has a call waiting with B
Phone D calls to A

If A decides to answer call from D
                  A should  disconnect call with C and retrieve D
Else        
                A stays with C connected and with B in hold on (waiting)

Updated

5 years ago
Duplicate of this bug: 852822

Updated

5 years ago
Component: Gaia → Gaia::Dialer
(Reporter)

Comment 2

5 years ago
Mozilla build ID: 20130304070202
(Reporter)

Comment 3

5 years ago
Dear Mozilla, 

Could you please update the status?

From QXDM log, there are three incoming calls:
MSG        [00063/02] Android QCRIL/High                04:24:26.292                qcril.c  01858  UI <--- RIL_UNSOL_CALL_RING (1018) --- RIL [RID 0, Len 4, (null)]
MSG        [00063/02] Android QCRIL/High                04:24:40.638                qcril.c  01858  UI <--- RIL_UNSOL_CALL_RING (1018) --- RIL [RID 0, Len 4, (null)]
MSG        [00063/02] Android QCRIL/High                04:25:03.955                qcril.c  01858  UI <--- RIL_UNSOL_CALL_RING (1018) --- RIL [RID 0, Len 4, (null)]

The 3rd imcoming call, send to UI:
MSG        [00063/02] Android QCRIL/High                04:25:03.955                qcril.c  01858  UI <--- RIL_UNSOL_CALL_RING (1018) --- RIL [RID 0, Len 4, (null)]
MSG        [00063/02] Android QCRIL/High                04:25:04.120                qcril.c  01858  UI <--- RIL_UNSOL_RESPONSE_CALL_STATE_CHANGED (1001) --- RIL [RID 0, Len 0, (null)]


UI get current calls status:
MSG        [00063/02] Android QCRIL/High                04:25:04.125                qcril.c  02644  UI --- RIL_REQUEST_GET_CURRENT_CALLS (9) ---> RIL [RID 0, token id 143, data len 0]
MSG        [00063/02] Android QCRIL/High                04:25:04.127                qcril.c  01772  UI <--- RIL_REQUEST_GET_CURRENT_CALLS (9) Complete --- RIL [RID 0, Token 143, Success, Len 12 ]

UI send message to hangup the 3rd incoming call:
MSG        [00063/02] Android QCRIL/High                04:25:04.175                qcril.c  02644  UI --- RIL_REQUEST_HANGUP_WAITING_OR_BACKGROUND (13) ---> RIL [RID 0, token id 144, data len 0]
MSG        [00063/02] Android QCRIL/High                04:25:04.175        qcril_reqlist.c  00675      RIL_REQUEST_HANGUP_WAITING_OR_BACKGROUND (13), token id 144
MSG        [00063/02] Android QCRIL/High                04:25:04.420                qcril.c  01772  UI <--- RIL_REQUEST_HANGUP_WAITING_OR_BACKGROUND (13) Complete --- RIL [RID 0, Token 144, Success, Len 0 ]

OTA LOG    [0x7B3A/003/008]CC/Call Confirmed                 04:25:03.890     Subscription ID: 0, Direction: MS To Network, Length: 29
OTA LOG    [0x7B3A/003/001]CC/Alerting                       04:25:03.897     Subscription ID: 0, Direction: MS To Network, Length: 2
OTA LOG    [0x7B3A/003/037]CC/Disconnect                     04:25:04.059     Subscription ID: 0, Direction: MS To Network, Length: 5
        cause_val = 17 (0x11) (User busy)

OTA LOG    [0x7B3A/003/045]CC/Release                        04:25:04.270     Subscription ID: 0, Direction: Network To MS, Length: 2
OTA LOG    [0x7B3A/003/042]CC/Release Complete               04:25:04.273     Subscription ID: 0, Direction: MS To Network, Length: 2


Thanks~
(Reporter)

Comment 4

5 years ago
Created attachment 728086 [details]
qxdm log
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853768
You need to log in before you can comment on or make changes to this bug.