If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Plaintext attachment starting with "From" is saved with ">" prepended.

RESOLVED DUPLICATE of bug 121947

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 121947
5 years ago
5 years ago

People

(Reporter: pkozbial, Unassigned)

Tracking

17 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 727112 [details]
The problematic attachment

User Agent: Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

1. I sent an email to a friend (using another email software, namely `mutt`).
    - this mail contained a text/plain attachment
    - the attachment started with the word "From"
    (actually, it was:
         From here
         to there.
    but without leading spaces (see attached file)).
2. My friend received the email with Thunderbird.
3. He saved the attachment to disk.
4. He opened the saved attachment with a regular text editor.


Actual results:

In the text editor, the attachment was shown starting with ">From".
(Prepended with ">").


Expected results:

It should be shown starting with "From".
(Just as it was sent, without ">").

HINT: It seems to me that this bug may result from using a mail receiving library which automatically prepends all "From " lines in a message body with ">". Such practice might have been introduced (in the library) for the benefit of traditional Unix mbox format. Cf. `man mbox`:

       Example:

        >From example@example.com Fri Jun 23 02:56:55 2000

       In  order to avoid misinterpretation of lines in message bodies
       which begin with the four characters "From", followed by
       a space character, the mail delivery agent must quote any
       occurrence of "From " at the start of a body line.

Comment 1

5 years ago
So this seems as correct behaviour according to the "standard".
However this is already filed as bug 121947 to find a workaround.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 121947
You need to log in before you can comment on or make changes to this bug.