bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Follow-up Bug 849186 memory optimizations for Import tasks in v1-train and master

RESOLVED FIXED

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jose Manuel Cantera, Assigned: crdlc)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ fixed)

Details

Attachments

(1 attachment)

188 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Reporter)

Description

5 years ago
In v1-train and master, consolidate memory-saving optimizations already implemented in v1.0.1 by bug 849186
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Updated

5 years ago
blocking-b2g: leo? → ---
Summary: Follow-up Bug 849186 memory optimizations for FB Import in v1-train and master → Follow-up Bug 849186 memory optimizations for Import tasks sin v1-train and master
(Reporter)

Updated

5 years ago
Status: NEW → ASSIGNED
Summary: Follow-up Bug 849186 memory optimizations for Import tasks sin v1-train and master → Follow-up Bug 849186 memory optimizations for Import tasks in v1-train and master
(Reporter)

Updated

5 years ago
Assignee: jmcf → crdlc
(Assignee)

Comment 1

5 years ago
Created attachment 727677 [details]
Patch v1
Attachment #727677 - Flags: review?(jmcf)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Updated

5 years ago
Attachment #727677 - Flags: review?(jmcf) → review+
(Assignee)

Updated

5 years ago
Attachment #727677 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 2

5 years ago
https://github.com/mozilla-b2g/gaia/commit/d2a68bc3c26312bbd70c926aedbdef0fc972805e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
This broke the unit tests : https://travis-ci.org/mozilla-b2g/gaia/builds/5804556

Is it possible to have a fast follow up to fix this please ?
Flags: needinfo?(crdlc)
(Assignee)

Comment 4

5 years ago
yes, in a couple of hours
Flags: needinfo?(crdlc)
(Assignee)

Updated

5 years ago
Blocks: 854840
(Assignee)

Comment 5

5 years ago
done Julien, thanks

Comment 6

5 years ago
Please request approval for v1.1 on the patch with a risk evaluation. We don't have any new memory requirements in v1.1, so this wouldn't be a blocker.
blocking-b2g: leo? → -
tracking-b2g18: --- → +
(Reporter)

Comment 7

5 years ago
Comment on attachment 727677 [details]
Patch v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Follow-up of bug 849186 memory optimizations that arose during the Buri certification. 
User impact if declined: High, we can face the same issues during leo certification 
Testing completed: Yes 
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: https://github.com/mozilla-b2g/gaia/commit/d2a68bc3c26312bbd70c926aedbdef0fc972805e
Attachment #727677 - Flags: approval-gaia-v1?(francisco.jordano)
(Reporter)

Updated

5 years ago
Attachment #727677 - Flags: approval-gaia-v1?(francisco.jordano) → approval-gaia-v1?

Updated

5 years ago
Attachment #727677 - Flags: approval-gaia-v1? → approval-gaia-v1+
Uplifted commit d2a68bc3c26312bbd70c926aedbdef0fc972805e as:
v1-train: b7227ce67b31354217beb0ee5a2101b6430c7370
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.