M092 Crash during download of Java Plugin [@ nsXPInstallManager::OnStatus]

VERIFIED FIXED

Status

Core Graveyard
Installer: XPInstall Engine
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: greer, Assigned: Syd Logan)

Tracking

({crash, topcrash})

Trunk
x86
All
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdt+] problem identified (dveditz), crash signature)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
This one is showing up in the talkback reports without much user comment. The 
few that have come in point specifically to java plugins.

(31532265) Comments: Download of Java-Plugin. Crash occured while FTP
transaction was running
(31472527) Comments: Java plugin installation

Stack Trace:
         nsXPInstallManager::OnStatus
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPInstallManager.cpp  line 849]
         nsFTPChannel::OnStatus
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFTPChannel.cpp  line
442]
         nsFtpState::StopProcessing
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp 
line 1776]
         nsFtpState::Process
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp 
line 584]
         nsFtpState::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\ftp\src\nsFtpConnectionThread.cpp 
line 406]
    nsXPInstallManager::OnStatus f32ad0bc
(Reporter)

Comment 1

17 years ago
Adding crash, topcrash keywords for tracking. As well as qawanted for help with 
repro steps.
Keywords: crash, qawanted, topcrash

Updated

17 years ago
Keywords: nsenterprise

Comment 2

17 years ago
Syd, what's the latest status on this bug?  Any chance of getting this resolved
for the next release?

Comment 3

17 years ago
This is the #2 topcrasher for Mozilla 0.9.2.  Here is the latest Talkback data:

nsXPInstallManager::OnStatus   205
			 85307 	 NEW 	  	 syd@netscape.com --- 
     First BBID :32340193
     Last BBID  :32421229
     Min Runtime :52
     Max Runtime :77254
     First Appearance Date : 2001-06-29
     Last Appearance Date : 2001-07-02
     First BuildID : 2001062817
     Last BuildID : 2001062823

Stack Trace: 

	 nsXPInstallManager::OnStatus()
	 nsFTPChannel::OnStatus()
	 nsFtpState::StopProcessing()
	 nsFtpState::OnStopRequest()
	 nsFtpControlConnection::OnStopRequest()
	 nsOnStopRequestEvent::HandleEvent()
	 nsARequestObserverEvent::HandlePLEvent()
	 PL_HandleEvent()
	 PL_ProcessPendingEvents()
	 nsEventQueueImpl::ProcessPendingEvents()
	 event_processor_callback()
	 our_gdk_io_invoke()
	 libglib-1.2.so.0 + 0xec40 (0x4035dc40)
	 libglib-1.2.so.0 + 0x10309 (0x4035f309)
	 libglib-1.2.so.0 + 0x10913 (0x4035f913)
	 libglib-1.2.so.0 + 0x10aac (0x4035faac)
	 libgtk-1.2.so.0 + 0x93c57 (0x40273c57)
	 nsAppShell::Run()
	 nsAppShellService::Run()
	 main1()
	 main()
	 libc.so.6 + 0x18a42 (0x4048fa42)     

(32420207)
URL: http://skraplotto.searchfaster.no
(32420207)
Comments: I tried to watch a JAVA-applet
     (32419000)	URL: www.virtualmarket.itb-berlin.de
(32419000)
Comments: visiting a heavy flash loaded site...
     (32416456)	Comments: Connecting to ftp.netscape.com to download java-plugin for mozilla
     (32415748)	URL: ftp.netscape.com
(32415748)
Comments: trying to download the Java 2 Plugin for Linux.failed to connect
several times.
     (32415629)	Comments: Download Java Plugin.
     (32414418)	Comments: I tried to install the Java plugin. It failed but this crash
happened about 2 minutes afterwards. I did absolutely nothing during that time
period.
     (32412698)	URL: http://mdc.lhsc.on.ca/main.html
(32412698)
Comments: Clicked location box to highlight and type in new URL
     (32408915)	Comments: Not sure. Had it sitting idle on another virtual desktop.
     (32404475)	URL: java.sun.com
     (32404475)	Comments: Try to install java 2 linux and all mozzil'as was rashed:-(
     (32403301)	Comments: installing java plugin
     (32402990)	Comments: I was DLing the JRE and it stopped mid-download and crashed a few
minutes later.
     (32401373)	URL: ftp.netscape.com
(32401373)
Comments: Trying to connect to the ftp server while server didn't respond.		
     (32401109)	URL: Don't know - random Google search.
     (32401109)	Comments: Canceled installation of java plugin.
     (32400969)	URL: www.starmedia.com.mx
(32400969)
Comments: opening the chat page
     (32400734)	Comments: tried to download java plugin
     (32399198)	Comments: I was downloading the Java engine required for some sites.
     (32397994)	Comments: Had given up as it kept failing
     (32397153)	Comments: trying to download the java2 plug in
     (32396657)	Comments: Downloading a Java 2 SDK
     (32393696)	URL: www.galefrocef1.com AND www.mozilla.org
(32393696)
Comments: trying to load java plugin (the default link to ftp.netscape.comhad
just timed out). reading the release notes for 0.9.2
     (32392385)	Comments: I was trying to change the search site in the preferences menu
     (32389368)	URL: http://www.deadly.org
(32389368)
Comments: Just browsing that page
     (32389249)	Comments: Trying to download the Java plugin
     (32388799)	Comments: i was downloading java plugin
     (32388602)	URL: ftp.netscape.com
(32388602)
Comments: I was running Mozilla as root
     (32387555)	Comments: pushing the back button twce
     (32387536)	Comments: trinyg to download java xpi thingo through smarkupdate
     (32387209)	URL: www.lamp.polito.it/fisica
(32387209)
Comments: again trying to download the same pdf document
     (32386419)	URL: ftp://ftp.netscaoe.com
(32386419)
Comments: trying to install java-plugin
     (32385889)	URL: http://www.freshmeat.net/
(32385889)
Comments: Fixing dinner.It was working fine when I left it to go do something
else.  I came back later to find the Talkback dialog staring at me and my
Mozilla windows gone.
     (32385616)	URL: www.lamp.polito.it/fisica
(32385616)
Comments: downloading pdf documentation
     (32385614)	Comments: Download Java2-Plugin.
     (32385584)	Comments: Was running Mozilla and netscape simultaneously.Went from window
with Mozilla to window with netscapeand mozilla crashed...
     (32385561)	Comments: several windows open... tried an ftp - download
     (32385275)	Comments: scrolling through a newsgroup
     (32384939)	Comments: Visited a page with a java applet. As I had no Java plug-in installed
     (32384939)	Comments:  dialog appeared saying "Connecting to ftp.netscape.com...".
Unfortunately my network connection was down and download failed. I tried again and
     (32384752)	Comments: It sat after asking for the download of the Java plugin
     (32384676)	URL: www.heise.de/ct
(32384676)
Comments: I was looking at a news article so i was actually doing nothing.Before
that the download of the Java 1.3-plugin failed.
     (32383814)	Comments: Trying to install java plugin.
     (32383297)	Comments: It was running in the background while I was working in Star Office
     (32381592)	URL: games.yahoo.com
     (32381592)	Comments: trying to download the java pluging for linux... it never works  [:(] 
(32380574)
URL: ftp.netscape.com
(32380453)
URL: ftp.netscape.com
(32380345)
URL: ftp.netscape.com
(32379114)
URL: don't have it anymore....
     (32378892)	URL: http://www.mozilla.org
(32378892)
Comments: Repeatedly trying to download Java 2 plugin after failures to connect
to netscape's ftp site
     (32378314)	URL: www.mozilla.org
(32378314)
Comments: Trying to get the freaking Java Plugin!!!
     (32377513)	URL: Java JRE 1.3.1 download
     (32377513)	Comments: Trying to download the java runtime while viewing several
different windows.
     (32377106)	Comments: trying to install the netscape6 jvm plugin into mozilla 0.9.2
     (32375972)	URL: ftp.netscape.com
(32375659)
Comments: Trying to install the jre.xpi to enable java support ( tried several
times but it wouldn't connect to netscape.com and eventually died)
     (32375554)	URL: www.bbc.uk
(32375554)
Comments: switching to another url www.mozilla.org
(32374276)
Comments: trying to install Java Plugin
     (32374009)	Comments: I was away from my machine at the time but the last thing I was
doing was downloading the Java plugin. While I was away the screensaver came on
and when I logged back in the Feedback agent was running.
     (32372429)	URL: http://zone.msn.com/bejeweled
(32372429)
Comments: I was trying to download the java jre plugin.  that fail probably cuz
my firewall
     (32372388)	URL: ftp://ftp.mozilla.org/pub/mozilla/releases/mozilla0.9.2/linux-xpi/
(32372080)
Comments: Clicking on the "Back" button
     (32370834)	Comments: Attempting to open link from HTML mail in new window after
clicking on the link and receiving no visible response.
     (32370529)	Comments: Mozilla went down when my internet connection was lost while
downloading the xpi. Mozilla seems to be unaware on a large scale of the MSWin
dialup net status.
     (32370239)	Comments: Trying to install the JVM through the browser assistant
     (32369881)	Comments: Trying to update the jvm
     (32369143)	Comments: I had started the download/install of the Java plug-in and left
the room.  When I came back
     (32369035)	Comments: the ftp connection to download the java vm failed to connect
     (32368918)	Comments: I clicked on a link at google in an attempt to solve my problems
with Java.  I had another window open where I was attempting to download the
plugin manually
     (32368918)	Comments:  longer valid?
     (32368820)	Comments: I think the java vm was being installed. 
     (32367839)	Comments: I was trying to download the linux java2sdk for the browser and it
failed (as it usually does when trying to connect) and I had the window open and
it just crashed.
     (32366811)	URL: dvd.box.sk
     (32366811)	Comments: I just was watching the page ;-(
     (32362435)	Comments: In the middle of typing in a URL
     (32362137)	URL: http://www.snowcrest.net/camera/
(32362137)
Comments: reloading  the page 
     (32361779)	Comments: The decode action seems worse than 0.9.1.And it's very impossible
to connect to ftp.netscape.com for Java Plug-ins.
     (32360973)	Comments: Downloading Java plugin for Linux from ftp.netscape.com
usingdefault address.  Referred by weather.com.Running as regular user.  Plugins
directory is world-writable
     (32360355)	Comments: I was looking at onsale.com while downloading the Java plugin forLinux
     (32360265)	Comments: Page with java applet
     (32360218)	URL: www.tribute.ca
(32359493)
URL: java.sun.com
     (32359493)	Comments: I wasn't using the browser. I was even in another desktop.
     (32359266)	Comments: loading the java2 plugin.. my machine couldnt contact
ftp.netscape.com via ftp
     (32358957)	Comments: I was attempting to send a new email message. After clicking 'new
message'the first time
     (32358957)	Comments:  and clicked 'new message' again. I wasbeginning to type text into
the body when Mozilla crashed.
     (32358108)	Comments: loading the plugins page
     (32357648)	Comments: Trying to download the Java plugin.(Also --- the
pagevorpal.mcs.drexel.edudoesn't display properly (garbage at the top).
     (32357028)	URL: ftp.netscape.com
(32357021)
Comments: preferences page
     (32356887)	URL: http:/netscape.com
(32356887)
Comments: I was downloading the Java plug-in for Linux and then Mozilla crash
     (32356672)	Comments: Trying to get java plugin for Linux
     (32356646)	Comments: Installing jre.xpi
     (32355833)	Comments: Just browsing
     (32355109)	URL: java.sun.com
     (32355109)	Comments: I was asked to download the java 1.3 plug-in.  I agreed
     (32354004)	URL: www.expanets.com
(32351051)
Comments: going from the 0.9.2 release page to the bugzilla page on glibc 2.1
bug.( doh! ) 
     (32348654)	URL: http://home.netscape.com/plugins/jvm.htm
(32348654)
Comments: Trying to install the Java2 plugin for mozilla.
     (32347491)	Comments: Browser crashed while trying to install Java plugin. It happen at
the beginning right after i clicked on the download button.
     (32346892)	URL: www.insidechess.com
(32346892)
Comments: browsing...
     (32343773)	URL: http://www.linuxtoday.com
(32343773)
Comments: Crash occured first time loading page with mozilla
0.9.2.username/password was stored as a cookie.using a proxy (junkbuster)
configured to allow outgoing cookies tolinuxtoday.com

OS: Windows 98 → Linux
Summary: M091 Crash during download of Java Plugin [@ nsXPInstallManager::OnStatus] → M092 Crash during download of Java Plugin [@ nsXPInstallManager::OnStatus]
(Reporter)

Comment 4

17 years ago
Also occurring on Win95, 98 and NT. Changing platform from Linux to All.
OS: Linux → All

Comment 5

17 years ago
pdt+   got a get this one fixed... its #2 on the top crash list for 0.9.2
Whiteboard: pdt+

Comment 6

17 years ago
jimmylee - have you seen this problem also?
Whiteboard: pdt+ → [pdt+]

Updated

17 years ago
Whiteboard: [pdt+] → [pdt+] No ETA. Trying to reproduce first and then Syd will look at.

Comment 7

17 years ago
No problems for me.  I get no crash downloading from both Linux and Windows.

Comment 8

17 years ago
I tried downloading simulating 56K connection (proxy host: chainsaw.mcom.com; 
proxy port: 8056).  The download dialog appears with the text "Transferring data 
from ftp.netscape.com", but no progress meter is displayed, and no bits are 
downloaded.  I waited a long time to be sure that nothing was going to get 
downloaded.  We're not even trying to install yet.  This was reproduced on both 
Linux and Windows.
The crash reports insist the crash happens at line 849, which is a simple 
return. The Assembly code clearly indicates an attempt to dereference a null, 
but I can't quite match the optimized assembly with what I can step through in 
my debug builds. My best guess is that mDlg is null on line 846.

There are a lot of places in the code where we don't check whether mDlg is null 
or not -- we were making a big assumption that since only the shutdown code set 
is to null we were always ok. In this case it looks like nsFtpState calls 
OnStatus after calling OnStopRequest. Normally not a problem, but in the case 
of a download error OnStopRequest can ultimately result in calling our Shutdown 
before the OnStatus comes in and tries to write to the now-gone dialog.

(we should really pop an alert telling users their download failed. Right now 
the dialog would simply close with nothing going on. We do write the error code 
into the install log and send it back to the web page, but that assumes the web 
page was written to display status. The SmartUpdate site did, but I'd guess 
that 99% of other sites don't)

A couple of simple options
 1) protect line 846 with "if (mDlg)"
 2) set mCancelled=PR_TRUE in Shutdown: this protects OnProgress too.
 3) add "if (mDlg)" to all unsafe uses of mDlg (nine places)

#1 will stop this crash, but #3 is probably the right thing to do to make sure 
we don't get bit by future crashes next time someone violates our assumptions 
about order of events.
Whiteboard: [pdt+] No ETA. Trying to reproduce first and then Syd will look at. → [pdt+] problem identified (dveditz)

Comment 10

17 years ago
Is #2 a safe thing to do?  If so, I would take #2 and #3 (assuming I could get
it quickly :-)  Any chance we can have this patch with reviews today or tomorrow?
Created attachment 42455 [details] [diff] [review]
patch following option 3
Created attachment 42457 [details] [diff] [review]
'-w' version of the above for readability

Comment 13

17 years ago
r=ssu for the patch id=42457

Comment 14

17 years ago
sr=mscott
The fix is in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
Build: 2001-07-17-05-0.9.2(WIN), 2001-07-17-03-0.9.2(LINUX)

Download does not fail for me on branch.  Then again, it never has.  So, please
track for those who track failures.  Adding keyword "vtrunk".  This needs to be
verified on the trunk.

Keywords: vtrunk
The trick for this one is that you had to have a necko error during the 
download, and it had to be from FTP.

Try ripping your network cable out of the machine in the middle of a download 
of something big (like Java).

Comment 18

17 years ago
Ripping the network cable out sounds quite harsh.  I opted to simply unplug it 
since I still needed it.  No crash was observed.  Needless to say, the download 
ended when the network cable was disconnected.

Comment 19

17 years ago
Build: 2001-08-01-06-trunk(WIN), 2001-08-01-08-trunk(LINUX)

Looks good on trunk.  Removing keyword "vtrunk".

Marking Verified!
Status: RESOLVED → VERIFIED
Keywords: vtrunk
(Assignee)

Comment 20

17 years ago
*** Bug 82630 has been marked as a duplicate of this bug. ***
Crash Signature: [@ nsXPInstallManager::OnStatus]
Keywords: qawanted
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.