Large PDF leads to crash in Print Preview

REOPENED
Unassigned

Status

()

P3
normal
REOPENED
6 years ago
3 years ago

People

(Reporter: wjones, Unassigned, NeedInfo)

Tracking

({crash})

19 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-performance], crash signature, URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 2013030600

Steps to reproduce:

1. View large PDF (1148 pages) using built-in viewer:
     http://www.ti.com/lit/ug/slau208m/slau208m.pdf
2. Select "Print Preview".
3. Select "Print".


Actual results:

1. Memory use grows rapidly.
2. Firefox crashes.


Expected results:

Print dialog should appear.

Comment 1

6 years ago
For me on Windows 7, it hangs during several minutes then it displays the print dialog. After dismissing the dialog, it hangs again and crashes with an empty signature.

Can you provide a stack trace (see https://developer.mozilla.org/docs/How_to_get_a_stacktrace_for_a_bug_report)?
Severity: normal → critical
Flags: needinfo?(wjones)
Keywords: crash, stackwanted

Updated

6 years ago
Component: Untriaged → PDF Viewer
(Reporter)

Comment 3

6 years ago
I have xosview open, and am watching free memory rapidly approach zero just before Firefox crashes.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 733324

Comment 5

6 years ago
The crash is bug 733324 but it's not normal that Firefox hangs and uses so much memory while print previewing.
Status: RESOLVED → REOPENED
Crash Signature: [@ libmozalloc.so@0x10d5 ]
Ever confirmed: true
Keywords: stackwanted
OS: Linux → All
Hardware: x86 → All
Resolution: DUPLICATE → ---

Updated

6 years ago
Severity: critical → normal
Priority: -- → P3
Whiteboard: [pdfjs-c-performance]

Comment 6

3 years ago
Warren, does this still fail for you?

Original URL fails, but the document is still available via https://web.archive.org/web/20130512121749/http://www.ti.com/lit/ug/slau208m/slau208m.pdf
Flags: needinfo?(wjones)
You need to log in before you can comment on or make changes to this bug.