Permission doorhanger for pointer lock should have an icon

RESOLVED DUPLICATE of bug 737100

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 737100
5 years ago
5 years ago

People

(Reporter: smaug, Assigned: shorlander)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
The patch for bug 737100 doesn't add any icon for the doorhanger.
I might be nice if it had an icon.
I wonder if the prompt should get a little wordsmithing too... "Would you like to allow the pointer to be locked on <site>?" seems like it might not be very clear to a user ("what's a pointer?"). Is there a way for the user to get out of pointerlock if the page doesn't release it (ESC or something)?
Component: General → Theme
Summary: Permission doorhanger for pointer lock could have an icon → Permission doorhanger for pointer lock should have an icon
(Reporter)

Comment 2

5 years ago
The patch isn't reviewed yet, so I do expect the message to change a bit.
(I certainly don't trust my English enough.)

The prompt does say that user can always use ESC.
(Assignee)

Comment 3

5 years ago
Created attachment 728229 [details]
Small notification icon
(Assignee)

Comment 4

5 years ago
Created attachment 728231 [details]
Small notification icon @2x
(Assignee)

Comment 5

5 years ago
Created attachment 728232 [details]
Large panel notification icon
(Assignee)

Comment 6

5 years ago
Created attachment 728233 [details]
Large panel notification icon @2x
I've rolled this into the latest (v11) patch in bug 737100. Thanks for the fast turnaround!
Assignee: nobody → shorlander
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737100
You need to log in before you can comment on or make changes to this bug.