Many java_vm processes spawned

VERIFIED INVALID

Status

Core Graveyard
Java: OJI
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: James Green, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I've accidently found a situation in which 17 java_vm processes were found in
memory. Not nice.

I was testing a page, http://www.itv-f1.com/ in a bug report, which contains a
java applet. The page doesn't fully load, and I hit Stop.

I then hit back, and entered a new bug into bugzilla, and stopped for a while.

Then I noticed I had 100 processes running. I normally have around 63. Running
'ps ax' I noticed a ton of 'java_vm' processes, 17 in total. Running 'pstree'
gives this:

     |-run-mozilla.sh---mozilla-bin-+-java_vm---java_vm---14*[java_vm]
     |                              `-mozilla-bin---3*[mozilla-bin]

Something or other is not at all healthy here. The only page open at the time
was a bugzilla page, thus the java plugin should not be loaded at all.

I'm running the latest java plugin from ftp.netscape.com, with mozilla built
from this morning's tip.

Comment 1

17 years ago
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
(Assignee)

Comment 2

17 years ago
I see this as well.
Status: NEW → ASSIGNED

Comment 3

17 years ago
Having lots of processes appear is not a bug.  This is the way linux (at least
red hat) implements multiple threads.  

Also, the browser may load the plugin to support liveconnect so it is possible
to see the java_vm processes even though you are not running and applet.  
(Assignee)

Comment 4

17 years ago
On 11 June 23:02:50, Jim Melvin - Java Software Engineering wrote:
> Hi Ed,
> 
> I'll let Steve reply to the bug, but this is the Linux process model.
> All threads show up as separate processes.  This is a well-known
> phenomenon on Linux.  If you need intimate details, please consult
> Calvin Austin.

Based on Jim's advice above, marking INVALID.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
*** Bug 102635 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Verified invalid
Status: RESOLVED → VERIFIED

Comment 7

16 years ago
*** Bug 115450 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Although marked as INVALID this is should be seen as a bug. These java_vm
processes spawned by mozilla are NOT killed when Moz exits. That's not a nice
use of resources.

Comment 9

16 years ago
*** Bug 145724 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I vehemently disagree with the analysis of this bug. The spawning of multiple
java vms is a massive change in operational behaviour from what existing
(Netscape Navigators) users see. Indeed with Netscape 4.6 under Linux the user
never see a java vm process. And now we get tonsof them. It's all very well to
lay the blame at the door of the JRE but that's a cop out. For testing of RC2 I
soft link to the same JRE I use with Netscape 4.6, which doesn't show any
rogue/duplicate/excessive java vms.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.