Usage line is wrong for "mach help <command>"

RESOLVED FIXED in mozilla22

Status

RESOLVED FIXED
6 years ago
8 months ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Trunk
mozilla22

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 727428 [details] [diff] [review]
patch

When you type "mach help build" or "mach build --help", mach prints:

  usage: mach [global arguments] command [command arguments] build
         [-h] [what [what ...]]

This patch changes it to:

  usage: mach [global arguments] build [-h] [what [what ...]]
Attachment #727428 - Flags: review?(gps)

Comment 1

6 years ago
I guess this is a dupe of bug 799322? But, this one has a patch, so let's preserve it.

Comment 2

6 years ago
Comment on attachment 727428 [details] [diff] [review]
patch

Review of attachment 727428 [details] [diff] [review]:
-----------------------------------------------------------------

Nice! And here I thought we'd have to monkeypatch argparse to get this right.
Attachment #727428 - Flags: review?(gps) → review+
(Assignee)

Updated

6 years ago
Duplicate of this bug: 799322

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/176b8aa6844d
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.