Intermittent TEST-UNEXPECTED-FAIL | jit-test\tests\asm.js\testTimeout1.js | --no-ion --always-mjit --debugjit: lib\asm.js:18:8 warning: asm.js type error: Disabled by debugger

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=20894709&tree=Mozilla-Inbound

WINNT 5.2 mozilla-inbound leak test build on 2013-03-20 09:39:14 PDT for push 9e684559ec7f
slave: w64-ix-slave12

FAIL - e:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\js\src\jit-test\tests\asm.js\testTimeout1.js
TEST-UNEXPECTED-FAIL | e:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\js\src\jit-test\tests\asm.js\testTimeout1.js | --no-ion --always-mjit --debugjit: e:\builds\moz2_slave\m-in-w32-d-0000000000000000000\build\js\src\jit-test\lib\asm.js:18:8 warning: asm.js type error: Disabled by debugger
Comment hidden (Treeherder Robot)

Comment 2

5 years ago
That's weird.  This is a --debugjit run so indeed asm.js should be disabled by the debugger, but then isAsmJSCompilationAvailable() should return 'false' because cx->compartment->debugMode() is true.  Also strange that this is intermittent...

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 3

4 years ago
I'm able to reproduce this by loading any page that runs asm.js once, opening either the debugger tab or clicking on a line that shows an error, then refreshing the page. The next time, it will show "Debugger is disabled". Currently I'm running Nightly 29.0a1 (2014-01-30).

Comment 4

4 years ago
Note that this will continue until you close the console, refresh the page and reopen it.
(Reporter)

Comment 5

4 years ago
Thanks for the report! However, this bug was filed for a specific test in our automated test suite falling intermittently, not for an issue in the browser. To get proper attention for your issue, please file a new bug. Thanks :-)

Comment 6

4 years ago
Yes, the Debugger disabling asm.js compilation is currently the expected behavior.
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.