Closed Bug 853291 Opened 7 years ago Closed 7 years ago

Add Polish (pl) to gecko localizations, central, mozilla-b2g18, mozilla-b2g18_v1_0_1

Categories

(Firefox OS Graveyard :: General, defect, major)

defect
Not set
major

Tracking

(blocking-b2g:tef+, firefox21 verified, firefox22 verified, firefox23 verified, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified)

VERIFIED FIXED
B2G C4 (2jan on)
blocking-b2g tef+
Tracking Status
firefox21 --- verified
firefox22 --- verified
firefox23 --- verified
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- verified

People

(Reporter: Pike, Assigned: Pike)

Details

Attachments

(1 file)

We haven't added the DT localizations to gecko yet, we need to do that.

The strings themselves aren't hard, we're on it, but the infra is tricky.

We need to add all of toolkit for each of the locales, which makes them quite heavy in download and update size.

Thus I advocate to only take 'pl' at this point.

We could be more generous if bug 848297 was fixed, though.

Upcoming steps:

Add polish b2g strings to l10n/mozilla-beta, -aurora, l10n-central.
Add 'pl' to b2g/locales/all-locales on central, b2g18, b2g18_v1_0_1.
Make sure that all that mirrors back into git and manifests.

Hal already started working on the git side, thanks.

Requesting shira+, impact if declined is English error messages when people hit network errors in the browser app.
ftr, the Polish strings are already in the l10n beta repo, all hail Stefan.
shira? -> tef?
blocking-b2g: shira? → tef?
I think this not my call, but I think this should be a blocker
Flags: needinfo?(mvines)
I agree with Daniel, and it's also not my call.
Flags: needinfo?(mvines) → needinfo?
Flags: needinfo?(ffos-product)
Flags: needinfo?
Polish is a required language for v1.0.1, so we can't default to English error strings. We just didn't want to break process (ownership of setting tef+). Marking appropriately.
blocking-b2g: tef? → tef+
I'd claim this patch is good to land, but I could really use a buddy to do the actual landing. The hotel wifi is really unreliable, and I don't have local clones for all the branches in question to start with.
Keywords: checkin-needed
Flags: needinfo?(ffos-product)
I'm back, going to land this now myself.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d41e05df1273
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
... and I still want to land them on aurora and beta, changing those flags from wontfix to affected. Requesting approval in a sec, to be on the safe side.
Comment on attachment 730420 [details] [diff] [review]
patch to add pl to gecko l10n for b2g

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: -
Testing completed (on m-c, etc.): -
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None

I'd like to add this patch to both aurora and beta to consistently expose those strings for the localizers.

This only impacts b2g builds, and we're not doing them from those repos yet, so this is mostly NPOTB. Requesting approval just to be on the safe side.
Attachment #730420 - Flags: approval-mozilla-beta?
Attachment #730420 - Flags: approval-mozilla-aurora?
No test case is needed for this issue.
Flags: in-moztrap-
Environmental  Variables:
Unagi Build ID: 20130402070202
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ccec751a468e
Gaia: ee0bef61c0a25c806dd1eec5a4e047bc418a5f73


Environmental  Variables:
Unagi Build ID: 20130402070204
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68c8a883cfc0
Gaia: 1c38c91bb16f2bf0d5066c4787d2249463f61bb3

Verified on V1.0.1 and V1.1.0 
 Polish(pl) language is added
Status: RESOLVED → VERIFIED
Attachment #730420 - Flags: approval-mozilla-beta?
Attachment #730420 - Flags: approval-mozilla-beta+
Attachment #730420 - Flags: approval-mozilla-aurora?
Attachment #730420 - Flags: approval-mozilla-aurora+
Approving for Aurora/Beta, since this is basically NPOTB.
Flagging for verification in Desktop builds using our automation.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.