Last Comment Bug 853340 - getTextAtOffset for word boundaries: beginning of a new life
: getTextAtOffset for word boundaries: beginning of a new life
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla22
Assigned To: alexander :surkov
:
:
Mentors:
Depends on:
Blocks: getText*a11y
  Show dependency treegraph
 
Reported: 2013-03-21 00:24 PDT by alexander :surkov
Modified: 2013-03-25 09:44 PDT (History)
4 users (show)
surkov.alexander: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (62.32 KB, patch)
2013-03-21 00:24 PDT, alexander :surkov
tbsaunde+mozbugs: review+
Details | Diff | Splinter Review

Description alexander :surkov 2013-03-21 00:24:25 PDT
Created attachment 727551 [details] [diff] [review]
patch

1) separate implementation for getTextAt word boundaries (not nice, I will reorg things during getTextAfter/Before work)
2) fix one case in GetPosAndText

The patch fixes bunch of cases and introduce couple regressions:
* couple regressions in getTextAfter/BeforeOffset because of GetPosAndText change (they don't seem important since these methods don't work in general)
* couple regressions in getTextAtOffset - layout says us hi (I will file bug for those)
Comment 1 alexander :surkov 2013-03-21 00:52:00 PDT
Trev, I need mochitests from bug 852021 before this. Also please don't be picky about this patch. It's in the middle of the work.
Comment 2 alexander :surkov 2013-03-22 02:08:17 PDT
What did we decide? Should I wait with landing until merging?
Comment 3 Marco Zehe (:MarcoZ) 2013-03-22 02:49:47 PDT
(In reply to alexander :surkov from comment #2)
> What did we decide? Should I wait with landing until merging?

No, go ahead and land this now. We have a full week to solidify it still, that's good enough for me.
Comment 5 Joe Drew (not getting mail) 2013-03-24 08:42:24 PDT
https://hg.mozilla.org/mozilla-central/rev/392c55ce512d
Comment 6 Trevor Saunders (:tbsaunde) 2013-03-24 12:32:10 PDT
so linux pgo builds started failing on this push in dom bindings while I don't really think its at fault I backed it out anyway in https://hg.mozilla.org/integration/mozilla-inbound/rev/3fd95a7e87de just to be sure
Comment 7 Phil Ringnalda (:philor) 2013-03-24 18:03:39 PDT
Relanded in https://hg.mozilla.org/integration/mozilla-inbound/rev/abef045c80bc once you turned out to be a completely innocent bystander.
Comment 8 Joe Drew (not getting mail) 2013-03-25 09:44:11 PDT
https://hg.mozilla.org/mozilla-central/rev/abef045c80bc

Note You need to log in before you can comment on or make changes to this bug.