Searching messages is STILL NOT working - false positives

RESOLVED DUPLICATE of bug 853393

Status

RESOLVED DUPLICATE of bug 853393
6 years ago
6 years ago

People

(Reporter: hawran.diskuse, Unassigned)

Tracking

17 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307164200

Steps to reproduce:

1. Clicked on a folder with messages (intentionally not on a root of my folders).
2. Right mouse / Search messages ...
3. Choosing "Run search on server" does not matter.
4. Match all of the following.
5. Body / Contains / <one word to find>
6. Search


Actual results:

A lot of messages has been found.

1. However, some messages without the word I'd been looking for.
2. Some messages with the word have not been not found.



Expected results:

1. No false positives.
2. All messages found.
(Reporter)

Comment 1

6 years ago
Name  Thunderbird
Version 17.0.4
User Agent  Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20130308 Thunderbird/17.0.4
Profile Directory  (Local drive)
Application Build ID  20130308141847
(Reporter)

Comment 2

6 years ago
#1. From the source of message I know there are:
- some hidden links with the word I was looking for ('TV' in particular)

#2. One of messages among those "not found" is of type:

Content-Type: multipart/related;
	boundary="_006_B4F41F4D532B3E429C7DEFCCE8ABE74F068A9CE94Bcznagmbx01int_";
	type="text/html"
MIME-Version: 1.0

--_006_B4F41F4D532B3E429C7DEFCCE8ABE74F068A9CE94Bcznagmbx01int_
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: base64
(Reporter)

Comment 3

6 years ago
I'm sorry, adding more info:

#1. From the source of message I know there are:
- some hidden links with the word I was looking for ('TV' in particular)
- some parts are base64 and the string 'TV' is there as well
Please don't file multiple bugs on the same issue. It isn't going to get your issue fixed any faster.

You may also find help at http://getsatisfaction.com/mozilla_messaging/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853393
(Reporter)

Comment 5

6 years ago
Well, I don't think these are duplicate bugs.

Please, take into account just point #1 (above) and regards these bugs as different ones.
(point #2 has been added as additional info, regarding searching for one word)
You need to log in before you can comment on or make changes to this bug.