Downloads Panel jumps with Download Statusbar

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
7 months ago

People

(Reporter: virgil.dicu, Assigned: Paolo)

Tracking

({regression})

20 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox20- wontfix, firefox21 unaffected, firefox22 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 727696 [details]
Downloads panel jumps while using Download Statusbar add-on

Reproducible on:
Firefox 20.0 beta 6 (20130320062118): Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:20.0) Gecko/20100101 Firefox/20.0
Latest Aurora: not reproducible
Latest Nightly: not reproducible

Add-on version 0.9.10

Steps to reproduce:
1. Open new profile and install Download Statusbar add-on from here: https://addons.mozilla.org/en-US/firefox/addon/download-statusbar/?src=hp-dl-mostpopular
2. Start downloading some large files (e.g. Ubuntu Desktop http://www.ubuntu.com/download/desktop/thank-you?release=latest&bits=32&distro=desktop&status=zeroc)
3. Click on Downloads Panel to see the status of the downloads.

Expected results:
Downloads Panel should be in it's place.

Actual results:
Downloads Panel jumps to a different position.

Notes:
Searching for a regression range.
(Reporter)

Comment 1

6 years ago
I tried to find a regression range. The bug is intermittent in mozregression, but after a second try I found the same pushlog, so this must be it.

Last good nightly: 2012-08-25
First bad nightly: 2012-08-26

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f077de66e52d&tochange=b3cce81fef1a

Maybe one of this bugs
Bug 748160 - Update the Downloads command to open the Downloads view instead of the Downloads Panel. Bug 747903 - Limit the number of items in the Downloads Panel.
Bug 748381 - Update the behavior of the Downloads indicator.
Bug 760607 - Update the Downloads Panel visual design.
tracking-firefox20: --- → ?
Keywords: regression
Doesn't look like a regression to me, looks more like the initial panel implementation, or something really close to it. That could even mean it's due to having the panel feature itself.
I'm not sure what Downloads Statusbar add-on does, must be debugged, it's unlikely we may find a safe fix for this though, at first glance.
We're about to build our final beta and since this is intermittent and possibly not a regression we'll leave it out of FF20 but will track for FF21 and beyond.
status-firefox20: --- → wontfix
status-firefox21: --- → affected
status-firefox22: --- → affected
tracking-firefox20: ? → -
tracking-firefox21: --- → +
tracking-firefox22: --- → +
Perhaps Paolo can look into this for FF21 and find a speculative fix for an early beta.
Assignee: nobody → paolo.mozmail
Setting needsinfo on Paolo to get an update on if there is any work-around fixes or investigation happening on this bug to fix within FX21 timeframe.

As a reminder Beta 4 which is going to build on Tuesday Apr 22 , will be the last opportunity to land any speculative fixes .
Flags: needinfo?(paolo.mozmail)
(Assignee)

Comment 6

6 years ago
Sorry for the late response. If I understand comment 0 correctly, this bug was
never observed in Firefox 21. I tried again now with the latest version of
Download Statusbar on Windows, and couldn't reproduce on these builds:

Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0
Flags: needinfo?(paolo.mozmail)
(In reply to Paolo Amadini [:paolo] from comment #6)
> Sorry for the late response. If I understand comment 0 correctly, this bug
> was
> never observed in Firefox 21. I tried again now with the latest version of
> Download Statusbar on Windows, and couldn't reproduce on these builds:
> 
> Mozilla/5.0 (Windows NT 5.1; rv:20.0) Gecko/20100101 Firefox/20.0
> Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0


whoops, sorry about that. In that case we should not have even tracked this bug . I just went by the tracking/status flags here which are not marked correctly.I will mark unaffected for Fx21.Thanks for the help on trying.

Virgil, please let us know if you are able to reproduce this on Fx22 and renominate in that case.
QA Contact: virgil.dicu

Updated

6 years ago
status-firefox21: affected → unaffected
status-firefox22: affected → unaffected
tracking-firefox21: + → ---
tracking-firefox22: + → ---
(Reporter)

Comment 8

6 years ago
- Couldn't reproduce for Firefox 21.0 beta 3 (20130416200523): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0; 

After STR from comment 0, I restarted Firefox, clicked the Downloads Buttons but it took no action (similar to bug 754389) so I could not test for the current issue.
Any thoughts? Should I fill a new bug for this behavior?


- Couldn't reproduce for Latest Aurora (20130422004013): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130422 Firefox/22.0

Same behavior as described for FF 21.0 beta 3.


- Couldn't reproduce for Latest Nightly (20130422105838): Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130422 Firefox/23.0

After STR from comment 0, I restarted Firefox, clicked the Downloads Buttons and instead of showing the list of donwloads in the Panel, a link with "Show All Downloads" appeared. (see attachment)
(Reporter)

Comment 9

6 years ago
Created attachment 740693 [details]
Latest Nightly with Download Status Bar installed
(Assignee)

Comment 10

6 years ago
(In reply to Virgil Dicu [:virgil] [QA] from comment #8)
> After STR from comment 0, I restarted Firefox, clicked the Downloads Buttons
> but it took no action (similar to bug 754389) so I could not test for the
> current issue.
> Any thoughts? Should I fill a new bug for this behavior?

Did that happen consistently, or intermittently? Did you see any messages in the
Error Console? You may want to see if this is the same intermittent case as
bug 754389, and if not file a new bug.

> After STR from comment 0, I restarted Firefox, clicked the Downloads Buttons
> and instead of showing the list of donwloads in the Panel, a link with "Show
> All Downloads" appeared. (see attachment)

If the download isn't in progress, it is expected that it disappears after a
browser restart, so this might be what you observed.
(Reporter)

Comment 11

6 years ago
(In reply to Paolo Amadini [:paolo] from comment #10)

> Did that happen consistently, or intermittently? Did you see any messages in
> the
> Error Console? You may want to see if this is the same intermittent case as
> bug 754389, and if not file a new bug.

This happens every time I download something and then restart Firefox.

Error console message:
[Exception...."TypeError: this.indicator is null" when calling method:
[nslDownloadProgressListener::on ProgressChange]" nsresult: "0x8057001c 
(NS_ERROR_XPC_JS_THREW_JS_OBJECT)" location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0" data:no]

Seems different to bug 754389, because has different STR. You need to restart FF to get the issue. Downloads menu is accesible from "Tools | Downloads" or Ctrl/CMD + J.

 
> If the download isn't in progress, it is expected that it disappears after a
> browser restart, so this might be what you observed.

Several downloads are in progress in Download Status Bar, as it can be seen at the bottom of the screenshot, in attachment from comment 9.

Comment 12

7 months ago
Going to assume it's no longer possible for add-ons to interfere with core UI like this.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.