Closed Bug 853495 Opened 7 years ago Closed 6 years ago

Rendering PDF incorrectly (unable to read all text)

Categories

(Firefox :: PDF Viewer, defect, P3)

19 Branch
x86_64
Linux
defect

Tracking

()

VERIFIED FIXED
Firefox 29

People

(Reporter: bugsnmd, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122351

Steps to reproduce:

Opened PDF file: http://www.unifem.org/attachments/products/EVAWkit_05_Factsheet_SafeCitites_en.pdf


Actual results:

Uncorrectly rendered - wierd colours across much of the page and text not fully readable


Expected results:

Open pdf in another pdf viewer and see!
this looks like a background transparency issue and is probably a dupe one of the other transparency bugs.

pdfs.js in the nightly also displays a compatibility warning.
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Looks better in nightly, but still is having a slight issue with soft masks.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 965861
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Keywords: verifyme
Verified as fixed on Firefox 29 beta 1 (20140318013849) under Win 7 64-bit, Ubuntu 32-bit and Mac OS X 10.8.5. The transparent area is correctly displayed.
The images from the top and bottom of the attached pdf are no longer displayed, I filed a new bug for this issue (see bug 986450).
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.