Devtools doesn't respect devtools.styleeditor.enabled pref

RESOLVED DUPLICATE of bug 1171939

Status

--
minor
RESOLVED DUPLICATE of bug 1171939
6 years ago
4 months ago

People

(Reporter: mark, Unassigned)

Tracking

19 Branch
All
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20130308 Firefox/19.0 PaleMoon/19.0.2
Build ID: 20130308232348

Steps to reproduce:

Opening the Inspector with devtools.styleinspector.enabled set to False


Actual results:

The Inspector shows a "Style" button. Clicking on this opens a black, non-functional style inspector side bar


Expected results:

The button should have been hidden (similar to other tools like Tilt) when disabled.
(Reporter)

Updated

6 years ago
Severity: normal → minor
Component: Untriaged → Developer Tools: Inspector
Hardware: x86_64 → All

Comment 1

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
On Windows 8.1 and FF nightly, devtools.styleeditor.enabled is not at all respected. 
The style editor button is not blackened and everything works as usual.

Comment 2

4 years ago
on windows 8.1 and FF nightly, The style Editor button is not blackened  working fine

Comment 3

4 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0

The Style button is displayed and works with devtools.styleeditor.enabled = false.
User agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0

Windows 8.1 and Firefox Dev edition the style editor is still being displayed but is not black or non-functional
User: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0

Same result with Windows 8.1 and Nightly, style editor is still being displayed but is not dysfunctional in any way.

Comment 6

3 years ago
windows 8.1 and FF nightly,
 The style Editor button is not blackened  working fine and in other OS it may be bug
(Reporter)

Comment 7

3 years ago
The style editor indeed seems to be working with the pref flipped off in the current release builds, BUT it's still not respecting the pref (not at all, now).

Of note, the pref seems to have been renamed to devtools.styleeditor.enabled in current versions.

Devtools still have the style editor button present and enabled, and the pref does absolutely nothing to disable it.
(Reporter)

Updated

3 years ago
Summary: Style Inspector button doesn't respect devtools.styleinspector.enabled → Devtools doesn't respect devtools.styleeditor.enabled pref
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171939

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.