Closed Bug 853552 Opened 9 years ago Closed 9 years ago

[B2G][Settings][Camera]: Camera shutter sound can be heard, when the camera sound option is OFF

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 851823

People

(Reporter: sarsenyev, Assigned: ben.tian)

Details

(Whiteboard: [TD-8411])

Attachments

(1 file)

Repro Steps:
1) Updated to Unagi Build ID: 20130321070203
2) From home screen, open "Settings"
3) Open "Sound" category
4) Under "Other sounds" category uncheck "Camera shutter"
5) Go back to the main screen and open "Camera" application
6) Tap on "Camera" icon to make a picture

Expected:
No sound can be heard when the "camera shutter sound" is off in options.

Actual:
The sound still can be heard.

Repro frequency:
100%

Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/7508c5a1026b
Gaia: 7af427d35c4d557c75b2060022815f07851acc28

Notes:
Test Suite Name: (Settings-Camera)
UCID: set-133
https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=3341
Q Analysts Test Team Priority Rating: (Pri 3)

Extra Notes: 
This bug reproduces in other languages as well.
Assignee: nobody → btian
Attachment #728115 - Flags: review?(sotaro.ikeda.g)
Underlying android CameraService plays the extra shutter sound since it is enabled by default. The patch disables shutter sound in CameraService because gaia camera app will play it.
It is same as Bug 851823.
Comment on attachment 728115 [details] [diff] [review]
Disable shutter sound in CameraService

It looks good to me. But I already saw a almost same patch in Bug 851823. It is better to close this bug as DUPE of Bug 851823.

Can you talk about how to handle the patch to Alexandre LISSY?
Attachment #728115 - Flags: review?(sotaro.ikeda.g) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 851823
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> Comment on attachment 728115 [details] [diff] [review]
> Disable shutter sound in CameraService
> 
> It looks good to me. But I already saw a almost same patch in Bug 851823. It
> is better to close this bug as DUPE of Bug 851823.
> 
> Can you talk about how to handle the patch to Alexandre LISSY?

I re-think about the above comment. I pushed your patch to Bug 851823. Can you handle the patch at Bug 851823?
Whiteboard: [TD-8411]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.