Closed Bug 85360 Opened 21 years ago Closed 20 years ago

movemail option disappeared

Categories

(SeaMonkey :: MailNews: Account Configuration, defect)

defect
Not set
critical

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 107833
mozilla1.0.1

People

(Reporter: ac131313, Assigned: racham)

References

Details

(Keywords: helpwanted, regression, relnote)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; NetBSD 1.5W macppc; en-US; rv:0.9.1) Gecko/20010611
BuildID:    0000000000

Would appear that movemail has simply disappeared from the list
of options.

Reproducible: Always
Steps to Reproduce:
1.Start up mozilla's mail tool
2.Choose Edit->Mail/News Account Settings
3.New Account
4.When you reach ``incomming server'' there are now
only POP and IMAP options.

Actual Results:  There isn't a movemail option for ``incomming server''.

Expected Results:  Provided a ``movemail'' option (even if it isn't apparently
supported).

NetBSD localhost 1.5W NetBSD 1.5W (NETLUX) #0: Tue Jun  5 10:40:27 EDT 2001    
boor@localhost:/usr/trunk.src/sys/arch/macppc/compile/NETLUX macppc


Mozilla 0.9.1
marking NEW.
Severity: blocker → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: other → NetBSD
Hardware: Other → Macintosh
Reverting to 0.9 shows same problem.

Workaround:

Create a movemail account using communicator 4.x in the .netscape/nsmail
directories.
Copy your e-mail into it's mail directory tree.
Trash the .mozilla directory.
Start mozilla.  It will import the communicator mail directory _including_ movemail.

Andrew (I've worked around it so it is no longer a ``killer'').
movemail option is absent in linux 2001062421 nightly build, too.
*** Bug 95109 has been marked as a duplicate of this bug. ***
This is missing badly. Not everyone wants to install 4.x to be able
to define a movemail account. Is there another workaround?
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
since this just seems to have postponed to 1.0.1 and many users will miss it: 
wouldnt it be nice to at least provide workaround info in the release notes
(of NS too)?
http://www.geocities.com/pratiksolanki/ seems to indicate that one way to
do this without 4.x is to define a pop3 account and then change the
user_pref("mail.server.server1.type", "pop3");  to "movemail". i didnt 
try it but if it works it will help a lot of people.
Keywords: relnote
if you want this in the release notes you must provide the exact text you
want added to the release notes to bug 108930, or whatever the current 
release notes bug is.
Added to CC.
eww. I used to use this a lot when I used ns4/mozilla mail. One dupe in almost a
year isn't encouraging, mind you, although if the option is migrated from ns4,
that may explain it.

-> all/all, although this option is unix only
Keywords: 4xp, mozilla1.0
OS: NetBSD → All
Hardware: Macintosh → All
The workaround described in Comment #2 does not help much.
Once you have done that, e-mail filters for your account do not work.
At least for me, that still keeps me from using Mozilla for mail.
I am currently running Netscape 4.79 for mail and most of my browsing
and Mozilla only for pages that Netscape cannot handle.
Once this bug is fixed, I can switch to 100% mozilla.
In my case (SuSE Linux 7.2) it works like described in Comment#2. You can't add
filter rules with the GUI but you can edit
~/.mozilla/user/XXX/Mail/YYY/rules.dat manually and mailfilter works. Besides of
that it is still annoying that one still has to edit rules.dat instead defining
filter rules with the gui like it was in ns 4.7.
Is anyone working in this ?
Not that I know of.
Keywords: helpwanted
Is this just a frontend matter? Are all options that were supported by 4.x
supported (and hence do exist preference settings) in Mozilla?
Some options such as external movemail handlers are
not supported.

I think the bug (as reported) really just describes a UI problem
though, specifically that there isn't one.  There's already a bug
for that, see bug 107833 (helpwanted)



*** This bug has been marked as a duplicate of 107833 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
IMO this should have been DUPed the other way round: this bug describes
a workaround which will help people how search for the bug, it has hints
to a related problem (activating filters for movemail accounts), it is the
older bug, and it has the severity higher than normal (i think major would
be apropriate).
It's true that this bug has those things going for it,
but IMO the other bug is much clearer in terms of an
actual bug report.
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.