cookie preference change saved incorrectly

VERIFIED WORKSFORME

Status

()

Core
Networking: Cookies
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Calvin Lin, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

the copy of my preferences in my user profile (from and older build of mozilla)
was set to accept cookies that were returned to the originating server.  i
wanted to change this, so when i opened up mozilla to change it, i was surprised
to find that it was reported as accept all cookies.

i hit okay with the expectation that it would overwrite my old preference, but
it did not.  i tried altering the cookie setting to other values and hitting
okay and then changing it back and it still did not correctly change the cookie
setting.  (i tested by attempting to send e-mail with http://mail.yahoo.com)

in order to get the cookie setting to actually change, i had to delete my
profile and rebuild a new one (actually converted from netscape settings). 
after i did this, yahoo mail worked fine (sending mail), so the cookie settings
seem to be correct.

Reproducible: Didn't try
Steps to Reproduce:
1. get an older build of mozilla and set it up to accept cookies returned to
originating server so that it is saved in your profile.
2. uninstall the old version and install the 2001060703 build
3. try to change the cookie setting to accept all cookies and try to get yahoo
mail to work (note, it will only fail to send mail when it has the incorrect
setting.)

Actual Results:  i have not done this because i haven't had time to set up an
old build of mozilla and create a profile etc.

Expected Results:  it should change the cookie setting in your profile to match
what you set in the preferences.  (and preferably it should report the setting
that is in your profile)

i believe this problem will implicitly be fixed when multiple user profiles are
addressed.  probably doesn't need to be addressed specifically.
->cookies
Assignee: dveditz → morse
Component: Preferences: Backend → Cookies
QA Contact: sairuh → tever
(Assignee)

Comment 2

17 years ago
tever, can you reproduce this?
(Assignee)

Comment 3

17 years ago
tevor, please let me know if you can reproduce this.  Thanks.
(Assignee)

Comment 4

17 years ago
Reporter gave a set of steps to reproduce but admitted that he hadn't actually 
tried it.  And q/a person has not responded to my question as to whether he can 
reproduce this.

Therefore I have no alternative but to close this out as works for me.  If 
anyone has evidence that this is still occuring and has a tried and tested set 
of steps for reproducing, then please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

13 years ago
has not bee na problem in any prefs testing I've ever done.
Status: RESOLVED → VERIFIED
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.