Support Default to Compatible for Firefox for Android 11.0 and up

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
3 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

unspecified
2013-03-28

Details

(Reporter)

Description

6 years ago
As discussed over IRC, we should support default to compatible for Firefox for Android. We support pretty much everything else:

https://github.com/mozilla/zamboni/blob/master/apps/constants/applications.py#L210-L216
What's the deadline for this?
The next release date is 04/02, so it would be best to have it done before then.
Well, we've hit 2 releases since this was reported...
Doh! three ...
It looks like this might be all we need to trigger default-to-compatible in most places:

diff --git a/apps/constants/applications.py b/apps/constants/applications.py
index 4d151e7..be9de55 100644
--- a/apps/constants/applications.py
+++ b/apps/constants/applications.py
@@ -209,6 +209,7 @@ for _app in APP_USAGE:

 # The lowest maxVersion an app has to support to allow default-to-compatible.
 D2C_MAX_VERSIONS = {
+    ANDROID.id: '11.0',
     FIREFOX.id: '4.0',
     MOBILE.id: '11.0',
     SEAMONKEY.id: '2.1',

There might some work in buttons.js to make the buttons behave, however. Anyone want to apply that and test it out?
fwiw: I will if someone tells me how to update / access that repo (a little out of my area) :-D
(Reporter)

Comment 7

5 years ago
The repository is here: https://github.com/mozilla/zamboni
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.