Unable to disable broken PDF viewer

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: John Hart, Unassigned)

Tracking

19 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Clicked on a link to download a PDF


Actual results:

Browser tries to open the file with out asking even though always ask is checked in preferences, sometimes fails to open it properly, then when saving re-downloads the file which is often corrupted.  


Expected results:

Browser should have asked what to do, and downloaded the file afterwords.  An easy way to revert to the previous unbroken version of Firefox would have mitigated what has become a very serious problem. Being able to handle PDF's correctly is one of the most important functions of a browser.
Please contact the support under http://support.mozilla.org and ask in the support forums.

Changing the PDF option works for me and the most likely cause for your problem is that you have changed the wrong entry in the application settings. ("Portable document format PDF" is the right entry).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

5 years ago
"Ask Always" used to bring up a menu that would let me view the file or save it. After the last upgrade PDF files no longer ask but just start loading.
(Reporter)

Comment 3

5 years ago
Created attachment 728002 [details]
Ask always option selected for five PDF types
(Reporter)

Comment 4

5 years ago
Created attachment 728005 [details]
Results after clicking link to pdf.

The browser didn't ask, loaded the PDF and gets an error.
Let me repeat my previous comment:

>the most likely cause for your problem is that you have changed the wrong entry in 
>the application settings. ("Portable document format PDF" is the right entry).

You screenshot in comment#3 doesn't show the "Portable document format (PDF)" entry
(Reporter)

Comment 6

5 years ago
It would have been nice if the new option would have inherited the settings from the old and appeared in the list next to the other PDF options!
The web and therefore the browser doesn't use file extension like .pdf
The content-type/mime-type is instead used and a webserver sends for every requested URL the mime-type together with the data. Examples are image/png, text/html or application/pdf. The decision what to do with the returned data from the webserver is done based on this mime-type.
The list in tools/application is therefore based on the mime-types and you get for each different mime-type an independent entry.
In many cases you get multiple entries for .pdf because some webservers send them incorrectly with wrong mime-types.
You need to log in before you can comment on or make changes to this bug.